PDA

View Full Version : Velvet drive trouble



dennis
06-25-2003, 04:49 PM
Hi again . '59 Owens 25' with a 283 and velvet drive .Finally got it running good and took it out yesterday and ran great all day until ...Iwas doing 2300 rpms and it popped out of gear.I shut it down and checked the linkage and for any other problems i could see .The linkage was fine no blown hoses. could that be the clutches slipping .I started back up and put in gear and nothing .I pushed the throttle up a little and the prop shaft started turning . so i headed for the barn. About five minutes later it popped out again and never turned again Vessle Assist to the rescue.Any input would be appreciated. Dennis

joe
06-25-2003, 11:54 PM
" Dennis, Check down on this page. A guy is selling two velvet drives. Might help you out. Joe "

kim
06-26-2003, 08:03 PM
" Before going and replacing the drive check your fluid level. It should be on the stick with engine and drive warm and idling. Also check for blockages in the tranny cooler and smell the fluid. Is it milky or discolored. Does it smell burnt. Also verify that the linkage is properly hooked up, with no slack, etc. Good luck and post your findings. Kim "

daniamarine
06-30-2003, 06:58 PM
" DOES IT SHIFT INTO REVERSE?
DANIA MARINE 1-800-748-7739
ILL BE GLAD TO HELP
THANKS, GABRIEL "

dennis
07-01-2003, 05:38 AM
No it would not shift into reverse either .the fluid level was fine .Is it hard to rebuild ? I mean do i need special tools like dial gauges .

Eddie Freeman
07-07-2003, 03:09 PM
" I have a 1986, twin 318 Chysler engine, (inboards)
The port engine is loading up with fuel and cutting off at idle speed. It will recrank right away. I am going to change the sparks pluga in both engine. Do you think that will help my problem.. The engine runs great... "

Eddie Freeman
07-07-2003, 03:11 PM
" oh one more thing. What is the proper spark plug gap for this type enegine..
318 inboards, chyslers. "

poker casino414
03-06-2006, 08:17 PM
"***** ****** ***** 448 ("")"