Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2007
    Location
    , Minnesota,
    Posts
    52

    Default "Is it normal to not get any w

    "Is it normal to not get any water out of the telltale when running on the muffs? Thanks in advance, Brian"

  2. #2
    Join Date
    Nov 2005
    Location
    lockhart, texas, US
    Posts
    5,812

    Default "no------u should always get w

    "no------u should always get water out of it---it is an indicator,of water in the powerhead."

  3. #3
    Johnson1989's Avatar
    Johnson1989 Guest

    Default "Try cleaning out the tube tha

    "Try cleaning out the tube that runs to the tell tale and the hole. Mine was once all plugged up with crap.. You can also look at where it connects under the hood, clean that out good also. IF not still you are probably looking a water pump overhaul."

Similar Threads

  1. 1974 merc 150hp water pump telltale
    By minit117 in forum Mercury Mariner Outboard Archive
    Replies: 1
    Last Post: 07-11-2009, 02:43 PM
  2. Johnson 70 hp exhaust smoke and no water at Telltale hose
    By bstephens in forum Johnson Evinrude Outboard Archive
    Replies: 1
    Last Post: 04-23-2009, 05:43 PM
  3. No water out the telltale
    By boatn_new_b in forum Johnson Evinrude Outboard Archive
    Replies: 1
    Last Post: 09-25-2008, 12:10 AM
  4. 1998 Merc 200 OB Overheating at High RPM No Water from TellTale
    By longfisher in forum Mercury Mariner Outboard Archive
    Replies: 4
    Last Post: 07-06-2008, 01:44 PM
  5. No Water from TellTale MERC XR 150 2005
    By gsmith3286 in forum Mercury Mariner Outboard Archive
    Replies: 4
    Last Post: 06-07-2007, 12:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •