MarineEngine.com - Your online store for all types of marine engines and boat parts.
PHONE ORDERS
Monday - Friday
9:00 AM - 5:00 PM EST
Click for TOLL-FREE Number
Online Checkout
Special $9.95 Flat Rate Shipping
(800) 209-9624 | Home | Contact | Shipping | Returns | Cart View your shopping cart.
Part Number Search
Shop by engine/drive part number.
Original & matching parts for sale.
Manuals & Accessories
Shop by description, item number
or manufacturer's model number.
Boat Repair Forum Boat Repair Forum   Boat Video Gallery Video Gallery
   
Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2007
    Location
    Jamestown, Tennessee, USA
    Posts
    2

    Default I have a '73 Johnson Seaho

    I have a '73 Johnson Seahorse 6HP that I just purchased. The motor had not run in 2-3 years. The fuel pump was out so I got one along with a new water pump impeller and installed both. It fired right up but no water came out of the "pee hole" I even reversed the impeller thinking it was in backwards. I NEED HELP!!!!!!! Any suggestions would be greatly appreciated.

  2. #2

    Default "Hi. I had the same problem w

    "Hi.
    I had the same problem with my 1971 6 hp johnson.
    After standing a while, the gasket between impleller-plate and housing had simply gone away with years. I used only gasket seal, and my motor now cooles really good.
    good luck!"

  3. #3
    Join Date
    Aug 2007
    Location
    Jamestown, Tennessee, USA
    Posts
    2

    Default Thanks I'll try that.

    Thanks I'll try that.

  4. #4

    Default "I have an Evinrude 7 1/2 hp 1

    "I have an Evinrude 7 1/2 hp 1972 or 73 and it doese not start showing water out of pee hole till it warms up for a few It does not seem to be over heatin and I am Wondering if this is normal as I dont have the original manual ??TIAV my email is (qlty@webtv.net}"

Similar Threads

  1. 1973 Johnson 40 hp.. more water problems..grrrr
    By Gorto72 in forum Johnson Evinrude Outboard Forum
    Replies: 7
    Last Post: 11-14-2010, 05:42 AM
  2. 1973 johnson 85hp problems
    By eyehunter in forum Johnson Evinrude Outboard Forum
    Replies: 1
    Last Post: 09-02-2010, 06:37 PM
  3. 1973 correct craft LM318 water hose routing for cooling
    By charliemitchell in forum Chrysler Inboard and Sterndrive Archive
    Replies: 0
    Last Post: 06-05-2008, 01:38 PM
  4. 1973 johnson 40hp workhorse water problems
    By mick bradley in forum Johnson Evinrude Outboard Archive
    Replies: 3
    Last Post: 09-12-2007, 06:31 PM
  5. 1973 Mercury 1150 115HP cooling system
    By waterman_shooter in forum Mercury Mariner Outboard Archive
    Replies: 3
    Last Post: 06-09-2007, 05:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •