MarineEngine.com - Your online store for all types of marine engines and boat parts.
PHONE ORDERS
Monday - Friday
9:00 AM - 5:00 PM EST
Click for TOLL-FREE Number
Online Checkout
Special $9.95 Flat Rate Shipping
(800) 209-9624 | Home | Contact | Shipping | Returns | Cart View your shopping cart.
Part Number Search
Shop by engine/drive part number.
Original & matching parts for sale.
Manuals & Accessories
Shop by description, item number
or manufacturer's model number.
Boat Repair Forum Boat Repair Forum   Boat Video Gallery Video Gallery
   
Results 1 to 3 of 3

Thread: Marine Power

  1. #1
    Join Date
    Jul 2007
    Location
    lansdale, pa, usa
    Posts
    1

    Default "I have twin MArine Power 350

    "I have twin MArine Power 350 Efi engines. Last year when I ran the boat at 3200 to 3400 Rpms everything worked great. However, If I bumped the Rpms to 3800 to 4000 Rpms the Port Engine would loose power and the tach would jump while the temperature gauge would climb to around 210 degrees. Now this year both engines are having the same problem even at 2000 Rpms. I have changed both water pumps and changed both fuel filters. If you can help I would appreciate it"

  2. #2
    Join Date
    Sep 2009
    Location
    Posts
    138

    Default Re: Marine Power

    we need some info how many hours on engs? it sounds like you could have a few thing going on if doing 3800 and the tack starts to jump you could be looseing ignition? the tack works off the minus side of the coil over heating is some thing different i would get a laser temp gun there pretty cheap and test the boat with the gun while running 3800 or even less see what heat you have at the risers manifold the block themostat housing the risers should be about 100 degrees aprox is this fresh water cooled? if so is it just the eng witch would a 1/2 system meaning the mans and risers are salt water cooled? also i would do a compression test? make sure its good like i said we need more info?

  3. #3
    Join Date
    May 2010
    Location
    hernando beach fl
    Posts
    6

    Default Re: Marine Power

    check the water hose from oil cooler to water pump if there is no spring in them they could be colapsing

    my engine did same changed hose runs cool now

Similar Threads

  1. Marine Power 454 won't restart
    By DriftnDrink in forum Marine Power Engine Forum
    Replies: 19
    Last Post: 09-08-2011, 09:13 AM
  2. Marine Power 350 efi
    By Sea Scouts - S. Florida in forum Marine Power Engine Forum
    Replies: 13
    Last Post: 04-11-2011, 07:35 PM
  3. No oil pressure 79b 454 marine power
    By kman in forum Marine Power Engine Forum
    Replies: 6
    Last Post: 04-20-2009, 11:58 AM
  4. Marine power 57 EFI
    By moflof in forum Marine Power Engine Forum
    Replies: 0
    Last Post: 08-25-2008, 01:14 PM
  5. Marine power problem
    By DanKK in forum Marine Power Engine Forum
    Replies: 0
    Last Post: 08-15-2006, 10:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •