Logo
Results 1 to 6 of 6
  1. #1
    Michael Tierney's Avatar
    Michael Tierney Guest

    Default " I have a 1977 Chris Craft wi

    " I have a 1977 Chris Craft with an original 305 in it. When it is cold, it starts very easily without hesitation. When the motor is running it is extremely smooth. After it has been warmed up and shut down, it will only start if I crank the starter for 5 to 7 seconds and only after I release the starter. I was told that it might be a ballast resistor problem but it does not have one to the best of my knoledge. I have put in a new ignition coil and I have also checked the choke to make sure that is operating properly.

    Any thoughts or suggestions would be appreciated.

    Thank you.

    Mike "

  2. #2
    Join Date
    Nov 2005
    Location
    Posts
    190

    Default " Just a shot in the dark, but

    " Just a shot in the dark, but replace the ignition switch. Disconnect battery and remove switch and see if your local NAPA store has one they have a good selection of both marine and auto switches. You do not have to try to get a Chrissy factory part as they use generic switches anyway. It sounds as if the switch has a high resistance reading on the ignition circuit terminals and this will only get worse as temp increases. Anybody else going to chime in with a suggestion?? Good luck and post your results. Kim "

  3. #3
    ChevyDude's Avatar
    ChevyDude Guest

    Default " It sounds like a bad resisto

    " It sounds like a bad resistor or electronic module in the distributor, if electronic. Try switching the module. It is only $20 at any local autoparts store. Have seen this happen many times in automobiles. "

  4. #4
    Join Date
    Sep 2006
    Location
    southgate, mi,
    Posts
    113

    Default I also have 1977 CC with 305.

    I also have 1977 CC with 305. The ignition switch on mine is a generic "Cole Herrse" available at West Marine. No ballast resistor on mine.

  5. #5

    Default " Do you have points or electr

    " Do you have points or electronic ignition ?
    If you have points you do have a resistor in
    ignition circut. This drops the voltage from
    12 volts to 8-9 volts to the distributor, to
    prolong point life. Voltage is droped by an
    inline ballast or by a coil with an internal
    resistor. When key is in start position, one
    small solenoid stud provides 12 volts to plus
    side of coil, for a hot 12 volt start. When
    key is released, you return to 8-9 run voltage.
    If no ballast resistor is present, your new
    coil, MUST have an internal resistor. "

  6. #6
    poker casino891's Avatar
    poker casino891 Guest

    Default "***** ****** [url=""]***** 42

    "***** ****** ***** 423"

Similar Threads

  1. Starting problem
    By mike_reichert in forum Johnson Evinrude Outboard Archive
    Replies: 5
    Last Post: 08-28-2009, 06:09 PM
  2. 50 MPI starting problem
    By alon in forum Mercruiser Sterndrive Archive
    Replies: 3
    Last Post: 11-24-2008, 07:28 PM
  3. Starting problem
    By watersport01 in forum Chrysler Force Outboard Archive
    Replies: 3
    Last Post: 04-12-2008, 01:36 AM
  4. Starting Problem
    By onewei364 in forum Honda Outboard Archive
    Replies: 3
    Last Post: 09-12-2007, 09:43 PM
  5. Starting problem
    By Jim Batten in forum Johnson Evinrude Outboard Archive
    Replies: 1
    Last Post: 03-22-2007, 11:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •