Logo
Results 1 to 1 of 1
  1. #1

    Default F225 battery charging problem

    2005 f225..Newer boat to me, 3 hours into a ride with a new cranking battery, I noticed my garmin shut off. It did again while I was using trim. My voltage (dash) read 13.5-14v but would drop to about 12 and shoot back up. I began to head back..soon after, I noticed my gauge dropping 13..12.. and instantly jump back to 14ish. It then would cut the motor every time I used trim. I made it back to the dock, my trim wouldn't go..and my starter would click... after I got home and I was expecting to find a dead battery..come to find out it was full as could be..12.8+. thinking corrosion/loose connections...anything else to check? I ohmed my battery clamps and I'd estimate 20% of surface area that successfully ohm. Otherwise they were coated.. the clamps weren't lead. Some tougher metal...
    Last edited by Maj92az; 06-26-2022 at 03:07 PM.

Similar Threads

  1. alternater not charging battery - how to determine problem.
    By lake of the woods in forum Crusader Marine Engine Forum
    Replies: 3
    Last Post: 07-30-2014, 05:02 PM
  2. Replies: 1
    Last Post: 12-23-2013, 10:21 AM
  3. Battery NOT charging current from alternator not reaching battery
    By keithpb45 in forum Pleasurecraft Marine PCM Forum
    Replies: 7
    Last Post: 01-02-2010, 10:49 AM
  4. Battery charging problem
    By rick_h_2 in forum Crusader Marine Archive
    Replies: 3
    Last Post: 07-07-2009, 01:33 PM
  5. 1997 Johnson 115 battery charging problem
    By fatboy in forum Outboard motors archive 2000-2004
    Replies: 4
    Last Post: 12-13-2002, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •