Logo
Click for Crusader parts and manuals!
Results 1 to 7 of 7
  1. #1
    Join Date
    Jan 2008
    Location
    Groveland, MA, USA
    Posts
    148

    Default Erratic High Idle 8.1 L MPI with 2007 ECM Engine s\n 670174 Manufactured 08/06

    Team:

    Port engine described above with the 07 ECM has an erratic high idle that oscillates between 800-1200 RPM. Ii is rock steady at dead low idle (660 RPM) and above about 1200 RPM. This engine sat for 3 years without being run.

    Rinda scan tool revealed no faults or error codes. The IAC valve stepper motor position was set a "0" and did not change during low idle when it was steady or high idle when it oscillated. Rinda Techmate Pro tool reported zero step position in both cases.

    I'm thinking it is a stuck IAC valve unfortunately on this engine that part is integral with the throttle body and not replaceable (whole new throttle body assembly is needed). The engine also has a stumble going from low idle to higher rpms when the throttle is moved quickly.

    Other possibilities are vacuum leak (but its steady at low idle) and throttle control position sensor. This engine has mechanical cables connected to an electronic throttle (TCP sensor).

    The starboard engine runs steady at high and low idle and I am planning to connect the Rinda scan tool to that motor and see what values it reads back from the the IAC valve. Another option is two switch over the TCP sensor from starboard to port and see if that corrects the problem. The TCP sensor is relatively inexpensive the entire throttle body is not.

    Would there be any gain removing the entire throttle body and cleaning it from the inside? The throttle body has a riveted plate (sealed) at the IAC Value location so you cannot access or remove the IAC Valve from the outside (picture attached).

    Any advice appreciated the unstable high idle is a problem in close quarter maneuvering.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Throttle Body side view.jpg 
Views:	7 
Size:	285.0 KB 
ID:	28689  

  2. #2
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    9,142

    Default Re: Erratic High Idle 8.1 L MPI with 2007 ECM Engine s\n 670174 Manufactured 08/06

    I'd rule out vacuum leak as the idle speed is low (vacuum leak = more air = increased RPM).

    I'd suggest starting with the RINDA unit and use the STBD engine to get some baseline data...say lowest idle, 1000 and 1200 RPM...check the inputs that you listed above along with the ECT ...it shouldn't be hard to see the delta's between the engine .

    FWIW, I can't say I ever remember working on an injected engine that idled without some IAC opening. That said, that ECM-07 is something I'm not fluent with.

    I may also have some data on the ETC...if I can find it, will deliver via the normal route.

    Glad you resolved the ignition switch intermittent.

  3. #3
    Join Date
    Jan 2008
    Location
    Groveland, MA, USA
    Posts
    148

    Default Re: Erratic High Idle 8.1 L MPI with 2007 ECM Engine s\n 670174 Manufactured 08/06

    Thanks Mako:

    Agreed cannot be a vacuum leak because at highest vacuum (low idle) it runs perfectly and the RPM is 660 = meets spec.

    I will definitely need a systematic and complete record of the relevant inputs and outputs for comparison between engines. Something's different. Another thing I haven't done is observe the behavior of the throttle plates in both engines as the throttle control is moved off dead slow idle to fast idle. I may just have something sticking (the engines did sit for 3 years) and I don't have any fault codes..

    In one of the manuals there were some screen captures of the Rinda Diacom output and the value of IAC Step # was 0 just like both my engines so for now that looks ok.

    Thanks for your help most appreciated.

  4. #4
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    9,142

    Default Re: Erratic High Idle 8.1 L MPI with 2007 ECM Engine s\n 670174 Manufactured 08/06

    There may not be a stand alone IAC...I'm thinking the DTC subsystem may incorporate that function...

    and something sticking/being gummed up is always worth checking...and eliminating...

  5. #5
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    9,142

    Default Re: Erratic High Idle 8.1 L MPI with 2007 ECM Engine s\n 670174 Manufactured 08/06

    The material I read today suggests the IAC function has been incorporated into the digital/electronic throttle control subsystem....I'd be inclined to concentrate the troubleshooting to those components initially. it could be a simple as the potentiometers used in the sensors are 'dirty' and their converted values are changing a little with each adjustment and causing the 'hunting phenomena'...the DIACOM s/w should be able to show it...

  6. #6
    Join Date
    Apr 2018
    Location
    NW chicago area
    Posts
    25

    Default Re: Erratic High Idle 8.1 L MPI with 2007 ECM Engine s\n 670174 Manufactured 08/06

    Dont know about crusader but I thought I ran across a service bulletin for a mercruiser ecm reflash for low rpm idle hunting. Thinking they are the same engines might also apply to yours. Phone call to crusader might save you some time and agrivation.

  7. #7
    Join Date
    Jan 2008
    Location
    Groveland, MA, USA
    Posts
    148

    Default Re: Erratic High Idle 8.1 L MPI with 2007 ECM Engine s\n 670174 Manufactured 08/06

    Thanks Crusader and Mercruiser use different ECMS so this likely does not apply. I'm gonna do some basic first things first testing and then go from there. I may have low compression from lower end damage or a stuck ring or valve or a misfire from a bad plug or injector -- the engine did sit for 3 years.

Similar Threads

  1. 2007 4 stroke idle high
    By captgarysr in forum Mercury Mariner Outboard Forum
    Replies: 1
    Last Post: 07-02-2020, 04:49 PM
  2. 15 hp Johnson 2007 Runs with high RPM but stalls anywhere near idle
    By Cpt. Jack Sparrow in forum Johnson Evinrude Outboard Forum
    Replies: 23
    Last Post: 11-12-2018, 12:56 PM
  3. Replies: 17
    Last Post: 07-27-2016, 06:14 AM
  4. 2007 mercury 30 hp 4 stroke high idle, iac valve or something else
    By ELKMO in forum Mercury Mariner Outboard Forum
    Replies: 2
    Last Post: 06-28-2016, 09:58 AM
  5. High RPM Engine Bog - 2007 350 Bravo III Mercruiser MPI
    By tjblinc in forum Mercruiser Sterndrive Forum
    Replies: 12
    Last Post: 07-10-2012, 11:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •