Logo
Results 1 to 4 of 4
  1. #1

    Exclamation Evinrude 9.5hp idle problems and armature plate lose.

    I have been trying to diagnose idle problems with my motor. I don't know the exact model since the serial tag is missing. I believe it is the 9222m model. The carburetor has been rebuilt and the motor has a new fuel pump. I went through the steps of adjusting the low idle jet but it seems to not want to idle in the low setting. I then noticed that the armature plate was loose. So I was thinking that since it was lose that it was throwing the points (or timing) off. I took off the magneto off and it was loose. I tried to tightening down the armature plate to the retaining ring and it was still loose. I read that if the armature plate is loose that I could try bending down the plate on the 12, 3, 6, 9 o'clock positions. That didn't work either. I thought it was missing crankshaft seal but can't really tell. I will upload a video of the looseness of the plate. My question, is this the problem and what can I do to fix this.


    https://youtu.be/6e2lNUO44nM

  2. #2
    Join Date
    Nov 2011
    Posts
    3,385

    Default Re: Evinrude 9.5hp idle problems and armature plate lose.

    Is the screw retainer plate (below the brass ring) upside down? Flat side goes up, tapered side down. It probably won't work either way, now that you've bent the brass ring.

  3. #3
    Join Date
    Sep 2010
    Posts
    22,482

    Default Re: Evinrude 9.5hp idle problems and armature plate lose.

    That small plate with the 4 holes is loose and it is not the problem.----What other trouble shooting has been done.----Post video of the coils and overall condition of this motor.-----Close up of the seal area at top bearing helps too.

  4. #4

    Default Re: Evinrude 9.5hp idle problems and armature plate lose.

    I had a 9.5 that was well used. Just about every piece of linkage from armature plate to carb showed wear. It would run ok, but would not idle as low as it should. Then I picked up an absolute museum piece that some kid pulled out of a barn and ran on straight gas. By the way, they will run about 20 minutes that way before throwing a rod... Anyway I put the powerhead off of the old one and put it on the new one and it now the same powerhead runs perfectly. The only difference being the amount of combined wear in all of the linkages.

Similar Threads

  1. 1979 Evinrude Armature Plate installation
    By Atvtrailrider in forum Johnson Evinrude Outboard Forum
    Replies: 12
    Last Post: 02-07-2021, 05:27 PM
  2. 1959 Evinrude 35HP Armature Plate slop?
    By woodlandfarms in forum Johnson Evinrude Outboard Forum
    Replies: 1
    Last Post: 08-13-2020, 08:38 AM
  3. 1985 Evinrude 30hp Armature plate problems
    By WeldPro in forum Johnson Evinrude Outboard Forum
    Replies: 2
    Last Post: 03-22-2020, 01:56 PM
  4. 25r74m armature plate
    By rmlm in forum Johnson Evinrude Outboard Forum
    Replies: 10
    Last Post: 03-30-2017, 10:04 AM
  5. 66 3hp armature plate?
    By blhotrod in forum Johnson Evinrude Outboard Forum
    Replies: 1
    Last Post: 01-18-2012, 06:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •