Logo
Click forPleasurecraft Marine parts and manuals!
Results 1 to 2 of 2
  1. #1

    Default ‘99 PCM 7.4L MPI Running Rich at Idle

    I have a 1973 Chris Craft Commander 41 refitted with 1999 PCM 7.4L MPI engines. One engine is running very rich at idle, to the point raw fuel is coming out the exhaust. I have the scanning software for the engines, so I have access to all the operating information.

    So far I have replaced the MAP sensor with no change. I have also checked fuel pressure, temp sensors, compression, and distributor. Timing is set at 10 BTDC at idle.

    From running a few trials with the scanner plugged in, the ecm is calling for about 15% more fuel on the rich engine than the good engine.

    I’m at a loss for what else to check and what would case the increased demand if the MAP sensor and Temp sensors are good.

  2. #2
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    8,545

    Default Re: ‘99 PCM 7.4L MPI Running Rich at Idle

    I was going to suggest maybe an injector is hung but you stated the ECU is calling for "more fuel"...assuming that's the case, across the RPM band, something is off.

    You said you "checked" some sensors - does that mean no DTCs or did you verify their accuracy with the scan tool/other engine? Many times, sensors go bad (loss of accuracy) and don't set a DTC.

    Do both engines make the same RPM at the same Throttle opening, under load?

    Any service done on the 'problem engine' within the past year?

Similar Threads

  1. johnson 120 VRO 88, Idle issue? Running Rich? Stalling
    By Rickstar in forum Johnson Evinrude Outboard Forum
    Replies: 6
    Last Post: 08-21-2019, 12:40 PM
  2. 150 Johnson running rich at idle
    By Bass stealth in forum Johnson Evinrude Outboard Forum
    Replies: 3
    Last Post: 06-02-2016, 03:19 PM
  3. Rough Idle, Running Rich?
    By dpomper in forum Johnson Evinrude Outboard Forum
    Replies: 3
    Last Post: 08-10-2015, 12:47 PM
  4. 2001 350 mag ski mpi Gen rough idle running rich
    By centurioneclipse in forum Mercruiser Sterndrive Archive
    Replies: 24
    Last Post: 07-14-2008, 12:59 PM
  5. 1975 75hp Merc rich running dies at idle
    By tmz in forum Mercury Mariner Outboard Archive
    Replies: 0
    Last Post: 07-05-2007, 03:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •