Logo
Results 1 to 3 of 3
  1. #1

    Default Engine not running right

    Hi I have a 225 John Deere in my fishing boat and when I come out of a tight turn from idol and give her throttle she only reeves up to 1500 no matter how much I give her once she’s going straight she goes right up to where she should be I changed the filters and still the same any ideas

  2. #2
    Join Date
    May 2015
    Location
    Oregon
    Posts
    146

    Default Re: Engine not running right

    Could be the tank pick up tube. A piece of debris might move over the tube when the fuel shifts.

  3. #3

    Default Re: Engine not running right

    Engine fuel filters or dirty water separator filter ?

Similar Threads

  1. Power assist steering is smooth as butter with engine running. Hard with engine off.
    By Bluecollerboater in forum Volvo Penta Gas Engine Forum
    Replies: 8
    Last Post: 06-17-2015, 09:31 AM
  2. Running one engine on twin engine boat
    By Bob F in forum Chrysler Inboard and Sterndrive Forum
    Replies: 2
    Last Post: 06-30-2010, 09:15 AM
  3. Power loss in Port engine (re: Port engine running rough)
    By gastite101 in forum Crusader Marine Engine Forum
    Replies: 5
    Last Post: 06-01-2010, 10:08 AM
  4. Replies: 5
    Last Post: 05-14-2009, 11:28 AM
  5. RUNNING ENGINE OUT OF GAS
    By bassman3112 in forum Johnson Evinrude Outboard Archive
    Replies: 7
    Last Post: 05-26-2007, 11:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •