Logo
Results 1 to 6 of 6
  1. #1

    Default Sea Star power assist issue

    Hello, Iím a new boat owner, and everything has gone well with the first week in the water until yesterday... I have a sea star power assist steering unit making some very loud noise. With the slightest turn of the wheel the PA unit starts making a very loud revving sound. Sounds like a weed wacker or a dirt bike, almost louder than my boats motor! It worked fine the week before. Any ideas? Thanks

  2. #2

    Default Re: Sea Star power assist issue

    https://youtu.be/lOjEc7tM1jw

    video link to the noise described. Even just the night before the unit worked fine and had no issues.

  3. #3
    Join Date
    Dec 2006
    Location
    Chaumont Bay, N.y., USA
    Posts
    6,015

    Default Re: Sea Star power assist issue

    Ayuh,..... Is there any oil in it,..??..??
    Any Grease is Better,... Than No grease at All....

  4. #4

    Default Re: Sea Star power assist issue

    Quote Originally Posted by bondo View Post
    Ayuh,..... Is there any oil in it,..??..??
    Went and got some oil and it would hardly take any so figured it was full. Iíve seen some people use the filler and bleeder kit hose while some people are able to just pour it in. Is it not full, and do I need the tube kit to get it to take oil? Is there air in the system that wonít let me put oil in? It ran fine the other day so if it is empty now does that mean I have a leak in the back which caused all this? Any help is appreciated. Thanks.

  5. #5
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,944

    Default Re: Sea Star power assist issue

    That noise is associated with pump failure.
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

  6. #6

    Default Re: Sea Star power assist issue

    Quote Originally Posted by Docksidemarineservices View Post
    That noise is associated with pump failure.
    Sea star support took a look at the video and determined it was a broken coupler. Theyíve got a new one in the mail to me already. They said when the coupler breaks the 12V motor will spin, making the noise heard, but isnít connected to the pump because the coupler is broken.

Similar Threads

  1. Broken power steer assist
    By Gyro in forum Mercruiser Sterndrive Forum
    Replies: 4
    Last Post: 05-31-2018, 12:49 PM
  2. Sea star ram issue and feedback
    By aristakat in forum Honda Outboard Forum
    Replies: 1
    Last Post: 01-27-2012, 06:54 AM
  3. Power steeringno assist
    By 57raven195 in forum Mercruiser Sterndrive Archive
    Replies: 16
    Last Post: 03-07-2008, 07:17 AM
  4. Power steering How much assist
    By bigblock4banger in forum Mercruiser Sterndrive Archive
    Replies: 3
    Last Post: 02-08-2008, 04:47 PM
  5. Star Power Diesel
    By chuck in forum Other Diesels Mfgs and General Diesel Questions
    Replies: 4
    Last Post: 04-26-2004, 03:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •