Logo
Click for Nissan Tohatsu Manuals, and Parts!
Results 1 to 28 of 28
  1. #1

    Default MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    2014 6hp with low hours.
    New fuel filter.
    Valves properly adjusted.
    Compression at 45+ with decompressor (I believe)
    Carburetor ultrasonic cleaned.
    New spark plug.
    New impeller.
    Good 87 octane no ethanol fuel.
    Oil at proper level.

    Anything over 1/4 throttle and it shakes and sputters like fuel starvation.

    Before I drop it off for 3 weeks at a mechanic I'd like to try again to fix it myself.

    Thank you.

  2. #2
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Verify timing. Re-check carburetor. Never replace just an impeller - always do a complete wp kit.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  3. #3

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Quote Originally Posted by pvanv View Post
    Verify timing. Re-check carburetor. Never replace just an impeller - always do a complete wp kit.
    Frankly I'm tired of removing and cleaning the carb
    It's been decades since I used my timing light. May not even be able to find it. Any suggestions on what one to buy?
    I assumed the timing would be ok if it ran great at idle and 1/4 throttle. Just ran it again and it's more like 1/3 throttle until it runs bad.

  4. #4
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Who cleaned the carb, with what method? I always do at least a 6 hr dunk in real carb dip in a heated ultrasonic tank, followed by a whole can of aerosol cleaner to flush all passages. If the power circuit is wrong (sounds like it), you may have missed installing something properly.

    I use a D-cell timing light like from electronics specialties.

    Is there a chance that the oil is above the full mark?
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  5. #5

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    My first cleaning was with about 1/2 can of carb cleaner and there was no change in the performance.
    I then soaked the carb in carb cleaner/degreaser in a heated ultrasonic tank overnight and then about 2 hours of ultrasonic cleaning, then 1/2 can or so of cleaner, then air.
    The mechanic said he would clean the carb as his first attempt. He may be able to do a better job than I, but I believe it is clean and I also believe I installed everything properly.
    Oil is not above the full mark.

  6. #6
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    I would do the same as your mechanic.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  7. #7

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    I verified the timing. close to 0 degrees TDC at idle and close to 25 degrees BTDC at full (rough running) throttle.
    I'm back to cleaning the carb again unless there are any other thoughts.
    I may buy a $30 can of Gunk Carb dip and use that instead of the carb cleaner/degreaser I have.

  8. #8

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    I only have a small tank at home.
    Is there an issue with testing in a tank in neutral or does there need to be a load on the prop?

  9. #9
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Yes, use real carb dip. Neutral is ok for running, but you would ideally be able to put it under load. You need at least 100 gal tank for that.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  10. #10

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Used real carb dip for about 8 hours at 130 degrees then 2 hours ultrasonic then flushed with 3/4 can of carb cleaner.
    Unfortunately no difference. Idles great. Blip the throttle and it responds. Hold is open past 1/3 and it sputters and runs very rough as it did in the beginning.

  11. #11
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Is there any chance the float height is wrong? Usually blipping the throttle is an issue due to being too lean...
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  12. #12

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Probably used the wrong term. By blip I mean I turn the throttle rapidly open then closed like warming up a motocross bike before a start.
    It doesn't stall or sputter when I do that.
    The float height is around 10mm depending an where I measure.

  13. #13
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    OK, so if oil is OK and timing is on, then you are either too lean or too rich. When you motor runs so poorly, stop and check the plug. Wet=rich... dry=lean.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  14. #14

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    I warmed it up then ran it full throttle for 15 seconds then pulled the plug.
    It didn't look wet.
    I have tried to insert a photo. I'm not typically technologically challenged, but this one got me.
    The plug is black.

  15. #15
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Carbon black is too rich. Oily black is something else.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  16. #16

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    I would describe it as carbon black for sure.
    How do I adjust that?

  17. #17
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Make sure you have the correct jets in the carb and the float height is correct.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  18. #18

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Float height is 9-10 mm depending on where I measure it. This is in line with service manual.
    I don't know about the jets except that the motor worked well prior to me owning it and nothing was changed.

  19. #19
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Did the motor ever sit with fuel in the carb for a week or more?
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  20. #20

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    I am sure it did. Probably for much longer than a week.
    I don't believe it ever had ethanol fuel in it.

  21. #21
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Probably needs a Proper carb cleaning then. Yes, sometimes it has to be done 3 times to get all the crud out of the tiny passages.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  22. #22

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    I dropped it off at a Tohatsu dealer/mechanic. He ultrasonic cleaned the carb and used a tiny bit to clean one of the jets on the upper side of the carb (slow jet?).
    I don't have a large tank and his was not 100 gallons like you mentioned, but it seems to run a little better.

    Before I get on the lake, I have one question on tank testing. Can you run it full throttle in a small tank for a short period to test it or does it have to have some load on it to be able to really know what's happening at full throttle?

  23. #23
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    It must be under load. Never go much above idle in neutral.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  24. #24
    Join Date
    Jun 2022
    Location
    Perrysburg, Ohio
    Posts
    3

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    I am new to the forum, and thank you for allowing me to join. I have an MFS6CS (same motor with a generator), and have a similar but more severe problem: Starts fine, idles forever, will run under load up to "restart" indicator, then runs fine for about 30 seconds and then dies...like you turned it off! I ran it dry before fogging and storage last fall and this spring it exhibited this from the get-go. Don't mean to intrude, but have been following this thread, and am guessing I have a fouled carb. One question: what is REAL carb dip? Thanks for letting me 'pop in'.

  25. #25
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    You really should start a new thread, but in my experience wrenching on these for 20 years, it sounds lean. Could be a leaky o-ring if running from external fuel tank, a weak fuel pump, or again the filthy carburetor. Real carb dip comes in 1-gallon cans at the auto parts houses. After it "shuts off", open the drain screw in the carb and see whether there is fuel in the bowl.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  26. #26
    Join Date
    Jun 2022
    Location
    Perrysburg, Ohio
    Posts
    3

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Paul, thank you very much. I am brand new using a forum, and apologize for not starting a new thread (is that the right term?) I searched Auto Zone and their dip is non-flammible. Walmart has Gunk dip and it is flammable. Which (if either) is better? I'll check the bowl. I already replaced the filter in the housing. I'll start at the (external) tank and work my way through the fuel system. Thanks all for your understanding.

  27. #27
    Join Date
    Mar 2010
    Location
    Hamburg, NY, USA
    Posts
    3,422

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    My tank holds about 3-4 gallons, and I have a couple of different brands mixed in. The new stuff is nothing like what we used to get back in the 70's and earlier. That stuff would take the hyde right off your hands, even after washing. Odds are you need to completely disassemble your carb, clean it, then reassemble.
    Paul
    Certified Tohatsu TLDI Technician
    Hamburg, NY USA

  28. #28
    Join Date
    Jun 2022
    Location
    Perrysburg, Ohio
    Posts
    3

    Default Re: MFS6C starts fine, idles fine, 1/4 throttle fine, full throttle runs bad

    Thanks, Paul. I'll get back to you when I've followed through on your suggestions. It is wonderful to have you, with all your experience, on this forum. I think we're very fortunate.

Similar Threads

  1. Replies: 12
    Last Post: 03-10-2017, 07:34 PM
  2. J25 starts and idles fine but stalls on adding throttle - what's wrong?
    By J25ELCI in forum Johnson Evinrude Outboard Forum
    Replies: 10
    Last Post: 10-30-2016, 08:55 AM
  3. 3 Cyl Johnson: Starts up fine, idles fine, runs slowly fine, but can't go fast
    By DrunkJ14 in forum Johnson Evinrude Outboard Forum
    Replies: 20
    Last Post: 06-16-2014, 09:36 PM
  4. Replies: 2
    Last Post: 09-01-2010, 12:18 PM
  5. Starts fine idles fine then loses power after 5 min
    By petergraves in forum Yamaha Outboard Forum
    Replies: 5
    Last Post: 08-09-2009, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •