Logo
Click for Volvo Penta parts and manuals!
Results 1 to 6 of 6
  1. #1

    Default VP 280 PT Trim Motor Problems

    Hey all!

    Over the months I've been able to get a lot of stuff reworked on my 280 with power trim. Cheers to Ricardo with all of his knowledge.

    I'm stuck with a bad trim motor, its original to the package and has what looks like a prestolite motor, that has an open cap at one end, where the shaft of the armature goes into the pump and oil well assembly.

    Any idea if there's a suitable replacement motor that crosses over to this trim motor assembly? Am I going to have to rewind it? The armature has been repaired so many times that it works only intermittently now.

    Many thanks.

  2. #2
    Join Date
    Mar 2019
    Location
    Ottawa Canada
    Posts
    532

    Default Re: VP 280 PT Trim Motor Problems

    I'm sure there is a replacement motor for it. It may cost too much. Maybe try looking for a used one.

  3. #3
    Join Date
    Mar 2009
    Location
    Portland, Oregon,
    Posts
    11,872

    Default Re: VP 280 PT Trim Motor Problems

    Unfortunately, the 280 PT OEM parts are no longer available. I'm not able to find a p/n for the entire pump, let alone the motor itself.

    You may be able to retrofit one of the later pumps.
    If the threads are not the same, a good hydraulic hose company may be able to install the correct line fittings onto your hoses.





















    https://www.ebay.com/itm/NEW-TRIM-MO...rd!97030!US!-1



    Here is one with a few adapters.






    https://www.ebay.com/itm/NEW-TILT-TR....c100005.m1851




    .
    Rick ... aka Ricardo..... AQ series Volvo Penta repair
    Portland, Oregon
    28' SDN F/B w/ twin Volvo Penta 5.7L DP drives

    "Intellectual growth should commence at birth and cease only at death." Albert Einstein

    Please... no PMs! Post your questions on the forum.

  4. #4

    Default Re: VP 280 PT Trim Motor Problems

    I was looking at a couple of these.

    Was hoping it wouldn't come down to a different motor/pump assembly.

    I have a couple calls out for armature winding/parts so I'll have to see where this goes.

    Thanks for the ideas, I'll probably look into the one with the adapters if I can't get anywhere. The sad thing is the rest of the pump/relays, etc are in amazing shape, no corrosion etc..

  5. #5

    Default Re: VP 280 PT Trim Motor Problems

    Quote Originally Posted by RicardoMarine View Post
    Unfortunately, the 280 PT OEM parts are no longer available. I'm not able to find a p/n for the entire pump, let alone the motor itself.

    You may be able to retrofit one of the later pumps.
    If the threads are not the same, a good hydraulic hose company may be able to install the correct line fittings onto your hoses.
























    .
    Super good news.

    I did a bunch of research, and found that the trim pump used on the aq280pt variants is common with a lot of mid 70s to early 80s Mercruiser stuff. The motor and reservior was very popular, and the variation was in the pump that bolts to the bottom of the reservior.

    Arco makes a current production replacement, model 6217. They also sell the motor shaft adapter for use in setups that require the longer motor shaft. I found a rebadged one on Amazon for 114$ Keep in mind this is only the motor and reservior assembly, no pump block on the bottom.

    I should be receiving mine by Saturday, and I'll test it out.

  6. #6

    Default Re: VP 280 PT Trim Motor Problems

    I have everything installed, and wired in. If anyone uses this replacement motor/reservior, make sure to pre tap the screw holes into the housing, it's easy to crack the plastic if the screw is too big.
    Click image for larger version. 

Name:	20200415-204041.jpg 
Views:	8 
Size:	306.6 KB 
ID:	23178

Similar Threads

  1. Johnson trim motor problems
    By Katdaddy in forum Johnson Evinrude Outboard Forum
    Replies: 16
    Last Post: 04-23-2020, 12:40 PM
  2. Trim Motor Problems
    By bluebass in forum Mercury Mariner Outboard Forum
    Replies: 3
    Last Post: 06-04-2017, 06:26 PM
  3. Operating AQ270 without trim motor - any problems?
    By DKaiser in forum Volvo Penta Gas Engine Forum
    Replies: 7
    Last Post: 02-11-2017, 07:45 AM
  4. Power trim motor problems
    By Grahamk in forum Yamaha Outboard Forum
    Replies: 0
    Last Post: 03-26-2015, 03:33 AM
  5. After installing new arco trim motor, trim gauge only points down
    By bkache in forum Johnson Evinrude Outboard Forum
    Replies: 1
    Last Post: 07-07-2014, 10:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •