Logo
Click for Honda Manuals, Parts and Model Guides!
Results 1 to 5 of 5
  1. #1

    Default 2004 225 key on no power no beep no nada

    Boat ran fine couple weeks ago.
    Batteries charged
    trim works at engine.
    fuses all look good, not sure which should have power with ignition not working?
    Power to starter
    power to alt.
    no beep or lights or clicks at key switch
    no volt meter or other meters.

    any advice?
    Thanks very much.

  2. #2
    Join Date
    Sep 2008
    Location
    Hague, Virginia, USA
    Posts
    4,691

    Default Re: 2004 225 key on no power no beep no nada

    First thing is check the big 30 amp fuse to on the right side of the fuse box - #7. Pull it and test it with an ohm meter.

    Next pull the wiring harness to your key switch and gauges where it connects to the ECU and inspect for corrosion or a burn't plug.

    Then, find the wires to the tach in your console and back track until you find the 7.5 amp fuse in the harness and check that.
    CHawk 25 DLX

  3. #3

    Default Re: 2004 225 key on no power no beep no nada

    Thanks I will check today.
    One question. Is the 7.5 fuse on the switch side or the motor side?
    Also, should I spray anything into the connectors after I check them.
    thanks

  4. #4
    Join Date
    Sep 2008
    Location
    Hague, Virginia, USA
    Posts
    4,691

    Default Re: 2004 225 key on no power no beep no nada

    The fuse is on the switch side.

    I'll try to post the wiring diagram here: Electrical Diagram Honda Digital Gauges Dual engines.pdf

    Yes, spray the connector pins with electrical cleaner.
    CHawk 25 DLX

  5. #5

    Default Re: 2004 225 key on no power no beep no nada

    Okay,
    checked 30 amp fuse it was good replaced it anyway.
    checked all connections under dash. Nothing looked burnt or wet.
    7.5 fuse tested good. Going to grab some electrical cleaner and spray all connectors. Is there a way to test power to the key switch to determine if switch is faulty?
    thanks

Similar Threads

  1. 2004 Mercury 50HP EFI Runs fine, but getting the 3 beep warning
    By mikesova in forum Mercury Mariner Outboard Forum
    Replies: 1
    Last Post: 07-04-2019, 05:35 PM
  2. 99 Merc 200 EFI alarm -beep beep beep beep
    By Bassdge in forum Mercury Mariner Outboard Forum
    Replies: 2
    Last Post: 01-10-2019, 08:15 PM
  3. Beep Beep Beep alarm - intermittent, not constant
    By Gary L in forum Mercury Mariner Outboard Forum
    Replies: 1
    Last Post: 07-15-2018, 09:51 PM
  4. Help 1992 60 HP Evinrude - turn on engine and after 5 minutes: beep, beep , beep
    By michael1983 in forum Johnson Evinrude Outboard Forum
    Replies: 3
    Last Post: 09-13-2014, 10:19 PM
  5. honda bf130 2004 long beep after run about 100 yrds
    By rmaharrey in forum Honda Outboard Forum
    Replies: 32
    Last Post: 08-31-2010, 08:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •