Logo
Click for Crusader parts and manuals!
Results 1 to 8 of 8

Thread: Please help

  1. #1

    Default Please help

    1979 fish natique.. 454 with 1410 marine carb . Pertronix dist and wires. Engine 2 years old carburetor and distributor system only 1 year old..park the boat late August and just trying to crank it this weekend and it is running rough and backfiring... I replace the spark plugs for process of elimination.. usually backfires when first giving it gas. Then again at idle I hear some popping out the exhaust..

  2. #2
    Join Date
    Mar 2009
    Location
    Dresden, Maine, United States
    Posts
    367

    Default Re: Please help

    Have you changed your fuel filters and how old is the gas? I would douse the tank with sea foam and see if that helps.

  3. #3

    Default Re: Please help

    Gas is 5 month old and was parked with seafoam . Fuel filter changed over summer .... I was reading last night ( dust cap may have moisture... Gonna eleimonate dat today

  4. #4
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    8,474

    Default Re: Please help

    a wet distributor cap can cause the popping noises you described....so can a leaking valve....

  5. #5

    Default Re: Please help

    Eliminated the wet distributor today. Unless corrosion settled in at some point. I'm afraid valve may be it... Strange thing is as I pull wires off one of the time most of them don't make a difference in the way th boat runs...also a shot of throttle cleaner into the carburetor will immediately back fire(
    Last edited by Tko8787; 01-13-2020 at 08:36 PM.

  6. #6
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    8,474

    Default Re: Please help

    did the wires get renewed when the distributor was?

    maybe its time to do a leakdown test?

  7. #7

    Default Re: Please help

    Unfortunately I got it figured out two bent push rods and two broken pushrods that fell down into the head. Milky water in port side head

  8. #8
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    8,474

    Default Re: Please help

    glad you found the source....bummer on the resulting findings...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •