Logo
Page 1 of 2 12 LastLast
Results 1 to 30 of 32
  1. #1
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Arrrghhhhh.

    1000 Hours.

    Engine has run great - until today. Went fishing for a few hours - boat started each time great. Engine got lower unit oil on it ( cap not tightened right ) so I decided to degrease the engine. Degreased and washed her. Rinsed it. Started her right up. Ran great at idle for 15 minutes, I was letting it get to operating temperature to help her dry off.

    Then, out of absolutely nowhere it stalled. And, will not restart. I don't even know where to begin. The engine is meticulously kept, all looks great - the only part that has been on my radar to replace is the ignition coil ( the rectangular 'cooling' metal on the coil ( not the cooling fins near the module ) looks a little rusty ). It did not overheat. Full fuel tank, fuel valve is turned on, when I turn ignition, I hear the fuel pump activate.

    I have to think that the engine degrease/ rinse had something to do with it - although I have done this infrequently before ( and the engine did start right up and read for 15 minutes ).

    I have never had this engine just stall like this - while at perfect idle.

    Anything pop into someones head right away ? I'm thinking to dump the water fuel separator and check for spark at a spark plug.

  2. #2
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Update - I was able to start her 1 hour later. She was hard to start and then finally started, ran rough for a few seconds and then smoothly. It smoked, which never happens, and I could smell fuel - also, something that never happens.

    I emptied the water fuel separator - it was clean.

    Note: this morning - before I went fishing - she started uncharacteristically rough too - she started and stalled a few times. That never happens.

    The only difference is it was colder this am than any other time of the season.

    Last year this happened the same time of the year too - in the cold, she was horrible to start. Over the winter, I. replaced the idle air valve thinking it was that. She's run OK, till now. Is there a sender or something that controls ambient temp ?

    This still would not explain why she stalled after idling for 15 minutes ?!

    Lastly, it may be me looking for something, but the 'fuel pump area' sounded louder today...
    Last edited by abl1111; 10-13-2019 at 03:41 PM.

  3. #3
    Join Date
    Dec 2017
    Location
    Kentucky
    Posts
    41

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Replace the IAC muffler. All it does is prevent a high pitch sound at idle. You could actually just remove it with no harm and see how it does. I have a 2002 5.0 MPI which is I believe the same set up as yours. I experienced very similar problems as you describe at around the same hours and this was the fix. Keep your flame arrestor clean. The breather hose from the valve cover gunks up the flame arrestor which in turn gunks up the IAC muffler which then over works the IAC. Once I learned to keep this system clean I've had no more problems. I replace the IAC muffler every year whether it looks like it needs or not. My 2 cents.

  4. #4
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    OK I'll check it out. Is it the muffler IAC or, there is another part in that area, the plug kit ( looks like they are interconnected to the throttle body ). In this same area, Last year I replaced the idle air valve.

    I have been using the boat and she has been running perfectly.

    I do find as the outside temp gets colder, 45 and colder, the engine struggles to start. Anybody have an idea what might be responsible for this ? Where to check ?

  5. #5
    Join Date
    May 2010
    Location
    DC Burbs/Maryland Eastern Shore
    Posts
    1,902

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    MAP/Temp sensor on intake manifold? If it is not sending correct signal it's possible that you're getting over-rich condition on start up.
    Practicing the ancient art of ren-ching

  6. #6
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    I like it - I'll check it out - thx...

  7. #7
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Update - ordered that part - but in the interim, went fishing today. Started real rough again - but started, then ran great... until, 45 minutes later after a run to the fishing grounds; put her in neutral at idle - she stalled ( an alarm went ). She started right up so I moved 5 minutes more, at speed, then, idled again - stalled again - and would not start. It was not a good place to have this happen.

    10 minutes later she started up again - I put her in gear and ran straight back home ! As I was at low RPM going, down the canal, she sputtered and stalled again - limped home...

    Synopsis ... Starts rough lately ( I assumed it was the cold weather - 36 degrees this am ). Runs great at anything over idle. Stalls at idle - will start right back up sometimes - or not. Hoping it's this MAP/Temp sensor - although, I'm not usually a subscriber to changing parts on a whim, figured it was a cheap ($50) way to find out...

  8. #8
    Join Date
    Sep 2003
    Location
    New Tripoli, PA, USA!
    Posts
    16,927

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    I'll bet you have contaminated fuel.

    Jeff

  9. #9
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Water / Fuel separator looked fine. Not sure where else I'd need to look to confirm bad fuel. I'm open to all suggestions.

    Would bad fuel affect the engine only at idle ? She just cuts right out.

  10. #10
    Join Date
    Jan 2010
    Location
    Posts
    1,028

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Is your engine serial number handy?

    You'll want to check fuel pressure before, during and after your symptoms described.

    When it won't start, have you tried opening the throttle handle any to help get extra air to the engine bypassing the IAC valve system?

    Did you happen to get the ECM wet any while washing the engine as it's close by the oil reservoir on a lot of engine model from Merc.

    Pull out and check some spark plugs to see if they look rich, etc.

    Has the distributor cap been changed at all? If so was it a OEM cap from Merc?

  11. #11
    Join Date
    Sep 2003
    Location
    New Tripoli, PA, USA!
    Posts
    16,927

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    I call it the "White Gook". This is what happens when ethanol fuel, moisture and time get together. It will go right through any and all fuel/ water separators and filters, and no lknown additive will make it burn. The only way to eliminate it is to get it out of your tank somehow.

    Jeff
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Gook.JPG 
Views:	17 
Size:	17.3 KB 
ID:	22141  

  12. #12
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    UPDATE

    Installed new MAP/ Temp sensor - same issue - so that's not it. Last year replaced the idle air valve ( these same symptoms were occurring, so I thought it was that ). Re-checked the fuel water separator and pre-filter ( SS canister thing before the water/fuel separator ). Both clean. I'm constantly running through fuel - and what I captured from water fuel separator was totally clean. My gut says its not a dirty fuel thing ( I've been wroing before ! )

    When cold, engine really does not want to start. I have to put throttle way up for it to fire - then when she starts I bring throttle down quick - first few seconds, runs really rough like its about to stall. Runs great. Idles perfectly. Let her run for like 15 minutes, she did not stall this time.

    But, when I turned her off and tried to re-start, it takes 2-3 tries to get her to start ?! Hard starting when normally she would fire right up.

    A thing I did find odd, the idle air valve has a small electrical component, like a solenoid - and it was F'ing hot ! As the engine ran it cooled down to a normal temp, but when I put my fingers on it, it was too hot to touch... For all I know this could be normal.

    Thoughts ? I

    I'm at a loss. Can't tell if its a fuel thing or an electrical thing.

  13. #13
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    This morning - Removed the IAC muffler. Boat still tough to start. Even when engine is warm she will be really tough to start. At idle, she stalled a few times for no reason - then again, tough to re-start. When she stalls, and alarm goes off first, then she stalls.

    ?

  14. #14
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    8,479

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Have you scanned the ECU yet ???

  15. #15
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    I was hoping to not have my mechanic get involved, but he has the ability to analyze the ECU and I do not. Hopefully he can figure it out quickly. I did unplug many of the sensors / relays while the engine was running so he will get false readings. But, I'm sure he can reset it all and then when it happens, he can hone in on the relay/ sensor/ sender - whatever the h*ll it is that is not functioning right.

    My logic has failed me.

  16. #16
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Waiting for mechanic.

    In the meantime, I replaced the Idle Air Valve ( everything was pointing to that ). Started up great. Ran her for 5 minutes. Turned her off. Tried to restart - could not - then I put throttle way up, she coughed and started. Ran her for 15 minutes - no stall. Started her 10-15 times - started each time.

    Any thoughts ?

    Aside from having a Gremlin !
    Last edited by abl1111; 11-06-2019 at 01:57 PM.

  17. #17
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Until mech can get there - any ideas ?

  18. #18
    Join Date
    Apr 2013
    Location
    Lower Columbia River
    Posts
    165

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Given that this started with giving the engine a bath, maybe a cracked distributor cap?

  19. #19
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Outta town. Will ck dizzy cap Monday

  20. #20
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Dizzy Cap fine. Now won't start at all. Mechanic can't get to it due to the seasonal winterizing craze.

    Stuck for now.

  21. #21
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    I read somewhere that the RPM's while cranking should be minimally 300 RPM's ( I think that's the spec ) to start.

    My tach shows much less than that, 100-200 RPMS. Thoughts ?

  22. #22

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Have you checked to see if you're losing spark?

  23. #23
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    I checked one of the plugs recently and it seemed to firing. Tough to do with just one person. I set it up and videoed the spark. Looked nice and white. to sure if it was sparking at the right time.

    The engine sounds like she is missing when I try to start her. Nothing has been tampered with so I know its not a crossed wire. I smell fuel and when I pulled the plug, she looked fouled with fuel.

    I bought online all the coil components i.e. ignition coil, ignition coil control heat sink etc, just to rule that out. Waiting for it to come in.

  24. #24

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Hook up timing light,if you're by yourself. You can see that from helm.

  25. #25

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    If you have no spark at idle handle position, then move remote handle to full throttle and see if you get spark.

  26. #26

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Spray a little starting fluid in throttle body. If you have any spark at all it will fire momentarily

  27. #27
    Join Date
    Sep 2003
    Location
    New Tripoli, PA, USA!
    Posts
    16,927

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    You need to find a buddy to help you out.

    Jeff

  28. #28
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Sprayed Gum Out in TB - nothing.
    When turning engine over my speedo is showing below 100 RPM's ?

    Will ck spark either later today or tomorrow...

    Can tell if my @$##%$^&^$$&^ battery charger is working ( know a quick test ? )

  29. #29

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Quote Originally Posted by abl1111 View Post
    Sprayed Gum Out in TB - nothing.
    When turning engine over my speedo is showing below 100 RPM's ?

    Will ck spark either later today or tomorrow...

    Can tell if my @$##%$^&^$$&^ battery charger is working ( know a quick test ? )
    Would think you don’t have spark then.

    probably easier to scrounge up a kown good battery

  30. #30
    Join Date
    Apr 2006
    Location
    Posts
    314

    Default Re: 2003 - 5.7L 350 - 300HP, Horizon MAG MPI - SUDDEN STALL ...

    Getting a battery now... Stay tuned

Page 1 of 2 12 LastLast

Similar Threads

  1. Water Pump shaft seal leaking 5.7, 350 Mag 300HP MPI - 2003
    By abl1111 in forum Mercruiser Sterndrive Forum
    Replies: 7
    Last Post: 07-14-2015, 05:34 PM
  2. 2003 Mercruiser Horizon 300
    By repilot in forum Mercruiser Sterndrive Forum
    Replies: 5
    Last Post: 07-06-2011, 09:36 AM
  3. New U-cooler question 2003 300hp
    By skytow in forum Crusader Marine Engine Forum
    Replies: 2
    Last Post: 10-07-2010, 10:10 AM
  4. Sea Ray 2003 340DA 81 Horizon Wonbt turn off
    By sad1 in forum Mercruiser Sterndrive Forum
    Replies: 32
    Last Post: 02-24-2010, 02:14 PM
  5. Magnum 350 300Hp
    By gkm24 in forum Mercruiser Sterndrive Archive
    Replies: 1
    Last Post: 06-12-2007, 08:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •