Logo
Get instant online access to repair manuals for your Mercury / Mariner outboard. Online Manuals
MercuryMariner
Order printed Mercury / Mariner service manuals — shipped to your door! Printed Manuals
MercuryMariner
Use engine diagrams to find & order parts for your Mercury / Mariner engine. Engine Diagrams
MercuryMariner
Find parts quickly with Mercury application guides. Quick Parts Guide
MercurySierraCDI
Results 1 to 9 of 9
  1. #1

    Default 2003 Mercury 125 Saltwater - Replaced Oil Level Sensor, Alarm Won't Stop

    I recently had the engine alarm come on. Upon examination I found the water pump was working properly, the engine block was cool enough to touch comfortably, and the engine had not over-revved in recent memory.

    I've gone in and replaced the oil level sensor with a new Merc part. Yet, the alarm still sounds constantly when the key is turned to the on position. The wiring from the sensor is a little confusing because both wires are blue but they connect to a black and brown wire. I've tried reversing the wires a couple time with no change. There is oil n the reservoir well above the sensor.

    I'm stumped. Is there a reset for the alarm? Is there a test procedure I can use. I would appreciate any advice. Thanks.

  2. #2

    Default Re: 2003 Mercury 125 Saltwater - Replaced Oil Level Sensor, Alarm Won't Stop

    Bad horn? Have you checked the overheat sensor?

  3. #3

    Default Re: 2003 Mercury 125 Saltwater - Replaced Oil Level Sensor, Alarm Won't Stop

    I have not checked the over heat sensor. Is that the same as the temperature sending unit depicted in the engine block diagram? What's the best way to test that: continuity, resistance,...? I didn't suspect the temperature sensor because the alarm sounds as soon as the key is turned on without starting the engine.

  4. #4

    Default Re: 2003 Mercury 125 Saltwater - Replaced Oil Level Sensor, Alarm Won't Stop

    I am still stumped. I located the temperature is sensor. However, it stuck tight in the head. I'm afraid I'll pull it apart if I pull on the wire too hard. Is there a way to test it without removing it. I have the dash panelmoff but I can't locate the warning horn. It sounds like it might be in the ignition switch assembly but I can't tell for sure. I also can't find anything in the parts diagrams on this site.

    I've tracked all the wiring to the point it goes into the big harness on the starboard side of the engine. All of that is intact and loos normal. The 20 amp fuse wired into that harness is good.

    Any advice on testing procedures would be greatly appreciated as this point. Thanks.

  5. #5

    Default Re: 2003 Mercury 125 Saltwater - Replaced Oil Level Sensor, Alarm Won't Stop

    So am I thinking correctly. If I test either sensor for continuity, with the condition they test for within normal ranges (oil level, temperature), they should show an open circuit. A closed circuit (continuity greater than zero) would send current to the alarm.

    The oil sensor is pretty straight forward, two wires, black to ground. The temp sensor has one wire. Looking at the photos in the parts diagram it's a bimetallic spring. When it gets too hot I might ground to the head and send a signal. These are my SWAGs. Can anyone offer some feedback.

  6. #6
    Join Date
    Sep 2010
    Posts
    17,554

    Default Re: 2003 Mercury 125 Saltwater - Replaced Oil Level Sensor, Alarm Won't Stop

    Does the alarm buzzer have an electronic circuit?-----If so then perhaps the buzzer itself failed.

  7. #7

    Default Re: 2003 Mercury 125 Saltwater - Replaced Oil Level Sensor, Alarm Won't Stop

    I'm not sure. The alarm is in the ignition switch. Not sure how to test that either

  8. #8

    Default Re: 2003 Mercury 125 Saltwater - Replaced Oil Level Sensor, Alarm Won't Stop

    I'm pretty sure that I figured it out. My new oil level sensor/switch is bad. I tested it for continuity and found the circuit is wide open, full continuity with no resistance. When I unplugged the sensor and turned the engine on the is no alarm. I'm not sure if MaineEngine.com warranties electrical parts. I'm going to find out.

  9. #9

    Default Re: 2003 Mercury 125 Saltwater - Replaced Oil Level Sensor, Alarm Won't Stop

    Thanks for the info; keep us up on your result.

Similar Threads

  1. 2003 Mercury 150 XL Saltwater
    By binspector in forum Mercury Mariner Outboard Forum
    Replies: 1
    Last Post: 07-31-2012, 07:37 PM
  2. 2003 90 HP Mercury Saltwater bottom carb flooding
    By wschonewitz in forum Mercury Mariner Outboard Forum
    Replies: 7
    Last Post: 11-08-2011, 05:28 PM
  3. Replies: 1
    Last Post: 10-23-2011, 09:08 AM
  4. Constant Alarm on 2004 Mercury 150 hp Saltwater series - help
    By gatorshane in forum Mercury Mariner Outboard Forum
    Replies: 7
    Last Post: 04-14-2011, 07:38 PM
  5. 2003 Mercury 150 hp saltwater misfire.
    By djelies in forum Mercury Mariner Outboard Forum
    Replies: 3
    Last Post: 07-13-2010, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •