Logo
Click for Volvo Penta parts and manuals!
Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2019
    Location
    San Diego
    Posts
    13

    Default Something doesn't look right with my outdrive

    Maybe I have never payed close attention to my outdrive but after replacing my gimbal bearing I notice there is a gap at the top. I don't know if i'm missing a gasket but I searched the diagram of my drive and don't see one listed. I would think this would allow water into the propeller shaft bellow. Am i crazy ?


    Click image for larger version. 

Name:	IMG_20190809_182047.jpg 
Views:	12 
Size:	58.0 KB 
ID:	21476Click image for larger version. 

Name:	IMG_20190809_182043.jpg 
Views:	10 
Size:	47.2 KB 
ID:	21477Click image for larger version. 

Name:	IMG_20190809_182038.jpg 
Views:	11 
Size:	38.5 KB 
ID:	21478 DP- SM Drive Unit
    Last edited by vlotta; 08-15-2019 at 06:17 PM.

  2. #2
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,537

    Default Re: Something doesn't look right with my outdrive

    It's Normal.
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

  3. #3
    Join Date
    Jul 2019
    Location
    San Diego
    Posts
    13

    Default Re: Something doesn't look right with my outdrive

    is there a reason for this space? Won't water get into the drive bellow area?

  4. #4
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,537

    Default Re: Something doesn't look right with my outdrive

    Quote Originally Posted by Docksidemarineservices View Post
    It's Normal.
    ..........
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

Similar Threads

  1. New prop doesn't fit
    By Maraian in forum Johnson Evinrude Outboard Forum
    Replies: 12
    Last Post: 09-18-2016, 04:17 PM
  2. Doesn't belong here but................
    By willow in forum Crusader Marine Engine Forum
    Replies: 6
    Last Post: 11-11-2013, 07:14 PM
  3. Water doesn't mix with Oil
    By moonman60 in forum Yamaha Outboard Forum
    Replies: 4
    Last Post: 04-11-2012, 08:38 PM
  4. 72 Johnson 20 HP doesn't run well
    By fastergun in forum Johnson Evinrude Outboard Forum
    Replies: 3
    Last Post: 08-29-2011, 06:31 PM
  5. doesn't run when in drive need help?
    By mike020304 in forum Volvo Penta Gas Engine Forum
    Replies: 1
    Last Post: 10-04-2010, 09:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •