Logo
Results 1 to 20 of 20
  1. #1

    Default merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    hello all, this boat has been kicking my butt. it is a late 90's MPI motor( replaced some time in the past, in a 93 searay now) serial # ow029060. the boat starts and runs fine then you take it out and it starts running rough at top end, i can hear the engine pinging and it starts stumbling, it pull back on the throttle and from that point forward it runs rough. sometimes never making it back to the slip and stalls out. it wont restart for several hours.
    ive checked the #'s on the scanner and the timing advance @ full throttle is between 28-32deg. no trouble codes, all gauges fine. this engine is non adjustable distributor. i have replaced the knock sensor and the coil/amplifier pack and yet still the same issue. all the basics have been changed, plugs, cap, rtr, wires. the fuel pressure is good @ 40psi @ full throttle. multiple ground cables installed, thinking it may have a voltage drop to the ecm. this boat has left me stranded multiple times , sea tow captain and i are on a 1st name basis. this engine has a lot of rust on it and it seems like every bolt is touch is rounded or frozen in place. even the bracket that holds the coild in place had to be replaced because the metal was flaking off and of course ,the bolts broke .
    i am about to rip the einjection system out of this boat and just put a good ole 4 barrel quadrajet and thunderbolt IV system in place and be done with it, and yes i know there are a lot of other things to change as well.
    thanks for the help guys
    Last edited by chs; 07-17-2019 at 09:13 AM.

  2. #2
    Join Date
    May 2010
    Location
    DC Burbs/Maryland Eastern Shore
    Posts
    1,658

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    A whole different boat seems like the correct answer to this problem. Personally I wouldn't spend another moment/penny on a boat that's trying to kill me.
    If the rust damage on the engine is as bad as you say then you're just wasting your time on it.
    Practicing the ancient art of ren-ching

  3. #3

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by o2batsea View Post
    A whole different boat seems like the correct answer to this problem. Personally I wouldn't spend another moment/penny on a boat that's trying to kill me.
    If the rust damage on the engine is as bad as you say then you're just wasting your time on it.
    ok, you have me curious. how id the different boat the answer to my problem?
    i guess you never swung a used motor into a car as a kid? come on? thats a right of passage in my history. chevy motors into a pontiac, pontiac motor into an oldsmobile, buick motors into a chevy.
    when you repower a boat you are putting a different motor in and this motor was a drop in complete drop in, bolt up and go. (plug and play) harness, computer and all. the only reason i mentioned it is because i knew someone would have pointed out that that motor did not come in a 93 searay.
    i mentioned the rust(externall) because of the likelyhood of voltage drop which i have found no sign of.
    Last edited by chs; 07-18-2019 at 09:27 AM.

  4. #4
    Join Date
    Jun 2006
    Location
    Spotswood, NJ, USA
    Posts
    4,882

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Have you pulled the injectors for cleaning

  5. #5
    Join Date
    May 2010
    Location
    DC Burbs/Maryland Eastern Shore
    Posts
    1,658

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by chs View Post
    ok, you have me curious. how id the different boat the answer to my problem?
    i guess you never swung a used motor into a car as a kid? come on? thats a right of passage in my history. chevy motors into a pontiac, pontiac motor into an oldsmobile, buick motors into a chevy.
    when you repower a boat you are putting a different motor in and this motor was a drop in complete drop in, bolt up and go. (plug and play) harness, computer and all. the only reason i mentioned it is because i knew someone would have pointed out that that motor did not come in a 93 searay.
    i mentioned the rust(externall) because of the likelyhood of voltage drop which i have found no sign of.
    Believe me I do plenty of wrenching and an engine swap is something I have done many many times. You describe a mediocre quality high production boat with not much in the way of redeeming qualities coupled with a rusted lump with fasteners that are well past their "use by" date. If one had to put a value on this combination it would be rather low. So low in fact that buying another boat with fewer problems will be far more cost effective than trying to resurrect this one.
    Maybe this one has some deep sentimental value and that's something else altogether. However, you gotta weigh the costs versus value. Also factor in you time. You don't work for free do you? Well when you work on projects that time cost needs to be added.
    Practicing the ancient art of ren-ching

  6. #6
    Join Date
    Apr 2013
    Location
    Lower Columbia River
    Posts
    142

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    I would run the engine off of a portable external fuel tank with new gas and a brand new fuel line from that tank to the fuel pump.

  7. #7

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by Bt Doctur View Post
    Have you pulled the injectors for cleaning
    i have not pulled the injectors however i did do a BG fuel induction cleaining on the engine this past spring. as maintenance. the problem really does not appear to be lack of fuel, when it craps out, i hit it with starting fluid and it does not kick so fuel is kind of ruled out, thanks fot the thought though.

  8. #8

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by o2batsea View Post
    Believe me I do plenty of wrenching and an engine swap is something I have done many many times. You describe a mediocre quality high production boat with not much in the way of redeeming qualities coupled with a rusted lump with fasteners that are well past their "use by" date. If one had to put a value on this combination it would be rather low. So low in fact that buying another boat with fewer problems will be far more cost effective than trying to resurrect this one.
    Maybe this one has some deep sentimental value and that's something else altogether. However, you gotta weigh the costs versus value. Also factor in you time. You don't work for free do you? Well when you work on projects that time cost needs to be added.

    why do you say "not much in the way of redeeming qualities "
    you know nothing about this boat, like the fact that it shines like it just came out of the mold, the upholstery and interior is meticulous, and so on.

    i dont understand why so many people come here for help and yes, its free but in turn we have to deal with people going off topic, and giving no real beneficial help to resolve the OP issue. instead, you get contributors calling other Morons, and cursing them out, , you get people suggesting fidiculous solutions sometimes i think just so they can see their name up on screen.


    to all those who feel they can help, please do and thank you so much, for the others who just want to be negative,go away

  9. #9
    Join Date
    May 2010
    Location
    DC Burbs/Maryland Eastern Shore
    Posts
    1,658

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Have fun with that. Bye
    Practicing the ancient art of ren-ching

  10. #10
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,697

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by chs View Post
    hello all, this boat has been kicking my butt. it is a late 90's MPI motor( replaced some time in the past, in a 93 searay now) serial # ow029060. the boat starts and runs fine then you take it out and it starts running rough at top end, i can hear the engine pinging and it starts stumbling, it pull back on the throttle and from that point forward it runs rough. sometimes never making it back to the slip and stalls out. it wont restart for several hours.
    ive checked the #'s on the scanner and the timing advance @ full throttle is between 28-32deg. no trouble codes, all gauges fine. this engine is non adjustable distributor. i have replaced the knock sensor and the coil/amplifier pack and yet still the same issue. all the basics have been changed, plugs, cap, rtr, wires. the fuel pressure is good @ 40psi @ full throttle. multiple ground cables installed, thinking it may have a voltage drop to the ecm. this boat has left me stranded multiple times , sea tow captain and i are on a 1st name basis. this engine has a lot of rust on it and it seems like every bolt is touch is rounded or frozen in place. even the bracket that holds the coild in place had to be replaced because the metal was flaking off and of course ,the bolts broke .
    i am about to rip the einjection system out of this boat and just put a good ole 4 barrel quadrajet and thunderbolt IV system in place and be done with it, and yes i know there are a lot of other things to change as well.
    thanks for the help guys

    Engine is newer than late 90's.....

    Find a good ecm from another engine, I have a few, so any good marina around you should have one you can borrow to test with. If you find an ECM to test with, drive your boat until it fails, swap the ecms and see if it restarts. You do not need to mount/ground it, just plug it in.
    Last edited by Docksidemarineservices; 07-22-2019 at 09:51 AM.
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

  11. #11

    Wink Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by Docksidemarineservices View Post
    Engine is newer than late 90's.....

    Find a good ecm from another engine, I have a few, so any good marina around you should have one you can borrow to test with. If you find an ECM to test with, drive your boat until it fails, swap the ecms and see if it restarts. You do not need to mount/ground it, just plug it in.

    thanks chris, unfortunetly, there are not any marinas willing to loan out an electronic part around here. wanna loan/send me one of yours?

  12. #12
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,697

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by chs View Post
    thanks chris, unfortunetly, there are not any marinas willing to loan out an electronic part around here. wanna loan/send me one of yours?
    Sure, there will be a $1800.00 deposit required.....LOL

    Where are you located?
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

  13. #13

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by Docksidemarineservices View Post
    Sure, there will be a $1800.00 deposit required.....LOL

    Where are you located?

    it may come to that. i am in connecticut

  14. #14
    Join Date
    May 2010
    Location
    DC Burbs/Maryland Eastern Shore
    Posts
    1,658

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    If it's the ECU, I'd Megasquirt it before spending a ridiculous 2K. Even Holly sniper is far cheaper and it runs right out of the box.
    Practicing the ancient art of ren-ching

  15. #15

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by o2batsea View Post
    If it's the ECU, I'd Megasquirt it before spending a ridiculous 2K. Even Holly sniper is far cheaper and it runs right out of the box.
    he is saying it is a deposit. not to buy it. he wants it back

  16. #16
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,697

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by chs View Post
    he is saying it is a deposit. not to buy it. he wants it back
    You do not need the exact ECM for your engine, As long as it is a 555 Alpha or Bravo for a 5.0, 5.7, 6.2, 383, 357 it will start your engine.

    There has to be a marina by you that has one you can test with.

    Do not change your FI system. It will cost you way more than a new ECM


    BTW, What type of circuit breaker do you have on your engine? Post a Picture.
    Last edited by Docksidemarineservices; 07-23-2019 at 10:16 AM.
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

  17. #17

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Quote Originally Posted by Docksidemarineservices View Post
    You do not need the exact ECM for your engine, As long as it is a 555 Alpha or Bravo for a 5.0, 5.7, 6.2, 383, 357 it will start your engine.

    There has to be a marina by you that has one you can test with.

    Do not change your FI system. It will cost you way more than a new ECM


    BTW, What type of circuit breaker do you have on your engine? Post a Picture.
    changing the FI system is the last thing i am thinking of, but tearing it out and putting a carb set up in, yeah, its a thought.
    the circuit breaker is a push button 50A and it was replaced last year.

  18. #18
    Join Date
    May 2010
    Location
    DC Burbs/Maryland Eastern Shore
    Posts
    1,658

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    When you put the carb system on it, remember that you will need a electric fuel pump and associated wiring and plumbing. The MPI engines don't have a fuel pump lobe on the camshaft, so you cannot bolt an engine driven fuel pump. There may also be differences in the way the control cable brackets attach, and in other plumbing wiring (like the choke).
    On the bright side, these engines don't need huge 4 barrel carbs. They are perfectly happy with a properly sized 2 V.
    Practicing the ancient art of ren-ching

  19. #19
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,697

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    It will also cost you an intake manifold and a new ignition system.......

    Changing to a carb is not an option unless you have very deep pockets.
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

  20. #20
    Join Date
    May 2010
    Location
    DC Burbs/Maryland Eastern Shore
    Posts
    1,658

    Default Re: merc 5.7 MPI motr runs rough, stalls after running at cruise for less than 20 minutes

    Carb= $500-700
    Gaskets, fittings=$200
    Wiring fuses terminals=$50
    Fuel Pump=$150
    Filter=$70
    hoses, clips, clamps=$50
    Misc hardware sealant and consumables=$50
    Distributor, coil=$350
    Wire set=$100

    Still under $2000, but I can probably find a really good running take out carb engine for about the same money.
    This is why I say that you are on the cusp of this boat not being worth the pursuit. The rabbit hole is deep on this, and you should consider what you are spending your boat dollars for.
    There are many many options. Consider renting; you buy only the time you are actually on the water, you probably get a nicer boating experience and at the end you drive away and let someone else deal with it. How many times can you rent for a weekend before you are past what you will spend on repairs and other expenses for the life of this boat? How many times will you be able to take this boat out? Every day? Once or twice a month? A year? What does it cost you per day to own it?
    If you decide to get this one going, what's the worst-case scenario? Complete repower? Is the boat's market value high enough to justify the expense? What if you need to buy another new ECU? Can you afford a big hairball of money like this, and what about if it needs something else after you get this challenge out of the way?
    These are valid questions that you have to ask, and don't think with your heart think with your head when you answer them.
    Take pride out of the equation. The only person who cares whether you repaired it yourself is you. Everyone else may be mildly interested and give you an "oh wow" when you tell them, but it doesn't matter.

    Yes, boats are fun, restorative and all that but they are just machines. If they are clunky and obsolete, drop it and move on to something better.
    Practicing the ancient art of ren-ching

Similar Threads

  1. 2005 mercury 9.9 Prokicker runs rough, runs good after 15 minutes
    By FireNHunt in forum Mercury Mariner Outboard Forum
    Replies: 0
    Last Post: 04-22-2016, 10:04 PM
  2. 2010 90HP EFI runs for 6 minutes and then slows to a rough idle.
    By hoppyfl in forum Mercury Mariner Outboard Forum
    Replies: 3
    Last Post: 04-15-2015, 10:25 AM
  3. 6 Hp Mercury starts runs for 10 minutes and stalls
    By tholepin in forum Mercury Mariner Outboard Forum
    Replies: 2
    Last Post: 07-24-2011, 12:43 AM
  4. 8 HP Honda runs for 10 minutes and then stalls canbt restart it
    By Geof Smith in forum Honda Outboard Archive
    Replies: 3
    Last Post: 10-01-2008, 09:20 PM
  5. Merc 225 EFI runs rough stalls
    By markG in forum Outboard motors archive 2000-2004
    Replies: 1
    Last Post: 08-29-2001, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •