Logo
Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2019
    Location
    Georgia
    Posts
    2

    Question 2002 5.0 MPI Fuel Problem.

    Newbie here. I have a 2002 Splendor 240 Platinum Cuddy Cabin. I have the 5.0 MPI GM engine with a Bravo 3 outdrive. The boat was running great and after shutting down to relax for a while, I turned the key on and after about 30 seconds the fuel pump finally turned on but would not shut off and sure enough wouldn't start either. Not sure what to look for but I did replace the relay and now have a spare. The fuel pump does shut off with the key but never shuts off pre-start like before running maybe 3-5 seconds.
    Any ideas?
    PS; not sure if I am posting in the right area either. Thanks, Steve

  2. #2
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    8,182

    Default Re: 2002 5.0 MPI Fuel Problem.

    Bravo 3 = Mercruiser....so you probably would have been better off to post to that section.....anyhow, welcome aboard!

    The 'pre-start' runs the fuel pump for a few seconds, is controlled by the ECU on a MPI engine....and since you replaced the relay, that's not the issue there....I'd suspect the ECU but would check it out before condemning it.

    As far as the no start goes, you need to have adequate fuel pressure in the rail (and the injectors to fire at the right time) and spark at the right time. usually one or both are missing for a no start...

Similar Threads

  1. 2002 Mercury 25hp - fuel delivery problem
    By Endo in forum Mercury Mariner Outboard Forum
    Replies: 5
    Last Post: 01-31-2017, 12:22 AM
  2. 2002 johnson 90hp fuel problem
    By joek in forum Johnson Evinrude Outboard Forum
    Replies: 9
    Last Post: 07-28-2015, 09:56 PM
  3. 2002 XR6 problem
    By perkinspiper in forum Mercury Mariner Outboard Forum
    Replies: 2
    Last Post: 04-19-2013, 12:04 PM
  4. 2002 merc 40 4 stroke efi fuel problem
    By shirer61 in forum Mercury Mariner Outboard Forum
    Replies: 3
    Last Post: 06-02-2011, 11:04 AM
  5. 2002 Yamaha F80 Four Stroke No fuel on output of Fuel Pump
    By blictg01 in forum Yamaha Outboard Archive
    Replies: 9
    Last Post: 08-28-2008, 05:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •