Logo
Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2019
    Location
    St Clair Co. Mich
    Posts
    2

    Default Cannot get water pump to pump

    So my motor was not really shooting water out the pisser very strong so i ordered a new pump and put it in. now i cannot get any water at all and it seems as though i no longer have a neutral position on my motor. I have taken it back apart a few times to check that i did everything right on the pump and it all looks good but it still wont pump.pulled the thermostat to check and i can blow air through the pickup tube and it blows out the stat hole.Help me with some ideas please.

  2. #2
    Join Date
    Sep 2010
    Location
    ontario
    Posts
    16,499

    Default Re: Cannot get water pump to pump

    I know you need to adjust the shift rod.----Look at it / see how the threads work---Possible left hand threads.-----I can not see your test set-up but more water in your bucket might help.

  3. #3
    Join Date
    Apr 2019
    Location
    St Clair Co. Mich
    Posts
    2

    Default Re: Cannot get water pump to pump

    I was using muffs with a water hose for testing.

  4. #4

    Default Re: Cannot get water pump to pump

    What about the tube going from the lower unit that brings water up to the powerhead.

  5. #5

    Default Re: Cannot get water pump to pump

    Motor year/model is helpful.

    No neutral and no water are are not associated w/each other. But if you had neutral prior to dropping LU then you reinstalled LU improperly. If you had water pissing prior to dropping LU amd now you don't after reinstalling LU then you installed the water pump improperly. If you don't have a year/model specific service manual , now is a better time than any. Essential for a DIY'r.

Similar Threads

  1. water coming out the cap hydraulic pump (power steering pump) that drives clutch?
    By 68seagoing in forum Chrysler Inboard and Sterndrive Forum
    Replies: 5
    Last Post: 10-20-2014, 07:40 AM
  2. 10 hp sportwin with new water pump wont pump water to head
    By 85stang in forum Johnson Evinrude Outboard Forum
    Replies: 0
    Last Post: 07-01-2012, 11:14 PM
  3. Water pump doesn't pump at slow idle Merc Classic fifty
    By chubmasterp in forum Mercury Mariner Outboard Forum
    Replies: 3
    Last Post: 08-06-2011, 08:53 PM
  4. Engine water pump on 43litre is seeping on backside of pump
    By beemerguy2000 in forum Miscellaneous marine engine topics
    Replies: 1
    Last Post: 06-15-2009, 10:55 AM
  5. 1992 Suzuki 225 water pump doesnbt pump water
    By rainey230 in forum Suzuki Outboard Archive
    Replies: 1
    Last Post: 07-15-2008, 05:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •