Logo
Click for Volvo Penta manuals!
Results 1 to 6 of 6
  1. #1

    Default TAMD73P wont' start, diagnosis and neutral lights won't come on

    Looking for ideas on why one of my engines (TAMD73P) won't start. Ran fine yesterday, but today....
    * turn key to 'on'
    * press red active station button
    * yellow diagnosis and green neutral lights do not come on and engine will not turn over when key turned to 'start'
    * both lights are good, they come on when I start in 'limp mode'
    * both stations in neutral (confirmed by looking at gearbox)
    * moving shift lever back and forth moves lever on gearbox fine
    * 12v power fine (can even start engine in 'limp' mode)
    * tried moving shift lever back and forth to find neutral, but neutral light does not come on
    * boat will go into forward, reverse, & neutral no problem when running in 'limp' mode

    Anyone know where the neutral safety switch is and how to test it?
    Any other ideas?

    Thanks!


  2. #2

    Default Re: TAMD73P wont' start, diagnosis and neutral lights won't come on

    Not neutral safety switch, I found it, jumped the terminals, nothing.

  3. #3
    Join Date
    Jun 2008
    Location
    Posts
    689

    Default Re: TAMD73P wont' start, diagnosis and neutral lights won't come on

    What sort of controls? Could the issue be in the 'station select' setup? If you have a 2nd station have you tried starting it with the 2nd station selected?

  4. #4

    Default Re: TAMD73P wont' start, diagnosis and neutral lights won't come on

    Quote Originally Posted by aliboy View Post
    What sort of controls? Could the issue be in the 'station select' setup? If you have a 2nd station have you tried starting it with the 2nd station selected?
    Other engine works fine on both stations, so I don't think that's it.

  5. #5
    Join Date
    Jun 2008
    Location
    Posts
    689

    Default Re: TAMD73P wont' start, diagnosis and neutral lights won't come on

    What sort of controls? Some have a relay in them that is activated when you push the station select switch and a bad relay will interrupt the start circuit. Have you tried manually applying 12v to the start circuit at the key switch to check for continuity and have you tried swapping the key switches between sides?

  6. #6

    Default Re: TAMD73P wont' start, diagnosis and neutral lights won't come on

    Quote Originally Posted by aliboy View Post
    What sort of controls? Some have a relay in them that is activated when you push the station select switch and a bad relay will interrupt the start circuit. Have you tried manually applying 12v to the start circuit at the key switch to check for continuity and have you tried swapping the key switches between sides?
    * I have a 'active station' button with 'diagnosis' & neutral' button/lights for each engine.
    * once pressing the 'active station', diagnosis should light, then out, then green neutral lights up and the engine starts.
    * currently, when I press 'active station', the diagnosis and neutral lights do not come on
    * I think the key switch is OK since I can use it to start the engine in 'limp' mode. You do this by holding the neutral button/light while turning on the key. This allows the engine to start, but will not rev up at all. Allows to 'limp' in an emergency situation.
    * all gauges and warning lights work on the panel

    It seems like the ECU is not relaying the 'start' signal, but I don't know who to test for this

Similar Threads

  1. Tach codes for TAMD73P
    By KalaKai in forum Volvo Penta Diesel
    Replies: 2
    Last Post: 05-20-2018, 11:43 AM
  2. 150 E-Tec System Check Lights Remaining On after Start Up
    By Wipsaw in forum Johnson Evinrude Outboard Forum
    Replies: 0
    Last Post: 03-09-2014, 01:41 PM
  3. Honda 225 won't start no lights at ignition
    By dscherz in forum Honda Outboard Forum
    Replies: 6
    Last Post: 07-27-2013, 08:04 PM
  4. Replies: 13
    Last Post: 07-08-2013, 02:39 PM
  5. 1998 454 XLi start issue diagnosis
    By djlenny in forum Crusader Marine Engine Forum
    Replies: 1
    Last Post: 02-07-2011, 03:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •