Logo
Get instant online access to repair manuals for your Mercury / Mariner outboard. Online Manuals
MercuryMariner
Order printed Mercury / Mariner service manuals — shipped to your door! Printed Manuals
MercuryMariner
Use engine diagrams to find & order parts for your Mercury / Mariner engine. Engine Diagrams
MercuryMariner
Find parts quickly with Mercury application guides. Quick Parts Guide
MercurySierraCDI
Results 1 to 13 of 13
  1. #1

    Default 2006 Mercury 60hp EFI Tilt/Trim Issue

    The issues I'm having is the motor will go down by itself when running in the water and also it will not trim up when I'm running it in the water. When I slow down (no load) it will trim up and down normal. So I trimmed the motor up and manually pushed down on the motor and it slowly goes down. I checked my cap. It was tight. I checked my fluid. It was at the appropriate level. The motor works fine. The cylinder goes up and down just fine. It is only an issue when the cylinder is under a load. The tilt/trim unit is on my Bass Tracker 175tw. I have never had a bit of problems out of it. I need all of the help that I can get. It was fine one day and not the next. Thank you

  2. #2
    Join Date
    Jun 2006
    Location
    Spotswood, NJ, USA
    Posts
    4,904

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    trim pump valves or cylinder O rings not holding

  3. #3

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    Quote Originally Posted by Bt Doctur View Post
    trim pump valves or cylinder O rings not holding
    Is there an o-ring kit to repair this? Or, will I have to buy a new pump and/or cylinder

  4. #4

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    I am going to try to bump this thread if at all possible. Searching for the right o-ring/seal kit for this has landed me nowhere.

  5. #5
    Join Date
    Nov 2011
    Location
    tennessee
    Posts
    3,751

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    If this is the single ram system most of the ones i see with this problem is the check valve/s in pump..about $100 ea. Usually customer gets a used one off Slezbay to fix.
    Pappys Sales and Service
    Owner and Factory Certified Technician
    Former racer KDBA (Kentucky Drag Boat Association)

  6. #6

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    Quote Originally Posted by faztbullet View Post
    If this is the single ram system most of the ones i see with this problem is the check valve/s in pump..about $100 ea. Usually customer gets a used one off Slezbay to fix.

    It is the single ram system. You have the motor on one side of the unit and the cylinder on the other. I will try to take it off and rebuild it, if I can. There are seal kits on Amazon for $30. I will search for the check valve as well. Thank you for your help.

  7. #7

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    Click image for larger version. 

Name:	check valve.jpg 
Views:	31 
Size:	15.9 KB 
ID:	22513

    Is this what you are calling a check valve? I pulled up the online parts catalog, and they call it a relief valve. Also there is ZERO fluid leaking anywhere, if that makes a difference.

  8. #8
    Join Date
    Nov 2011
    Location
    tennessee
    Posts
    3,751

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    No ..this and there are 2 of them in pump.

    Pappys Sales and Service
    Owner and Factory Certified Technician
    Former racer KDBA (Kentucky Drag Boat Association)

  9. #9
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,769

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    Quote Originally Posted by jasonbradmorris View Post
    Click image for larger version. 

Name:	check valve.jpg 
Views:	31 
Size:	15.9 KB 
ID:	22513

    Is this what you are calling a check valve? I pulled up the online parts catalog, and they call it a relief valve. Also there is ZERO fluid leaking anywhere, if that makes a difference.

    Make sure this is tight, if it is loose it will cause the issue you are having.
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

  10. #10

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    Quote Originally Posted by faztbullet View Post
    No ..this and there are 2 of them in pump.

    well, crap...I wish I waited for your answer now. I ordered the other thing so that I had it by the weekend. How do I know if this has gone bad if there is ZERO fluid leaking out of anything?

  11. #11
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,769

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue



    Did you make sure this screw is tight?
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

  12. #12

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    Quote Originally Posted by Docksidemarineservices View Post


    Did you make sure this screw is tight?
    I have not started working on it yet. I got busy yesterday and didn't get a chance to work on it.

    If any of this stuff is leaking, shouldn't I have oil coming from somewhere?

  13. #13
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,769

    Default Re: 2006 Mercury 60hp EFI Tilt/Trim Issue

    Quote Originally Posted by jasonbradmorris View Post
    I have not started working on it yet. I got busy yesterday and didn't get a chance to work on it.

    If any of this stuff is leaking, shouldn't I have oil coming from somewhere?
    This screw is the bypass to raise or lower the engine with out the use of the electric motor. It does not leak fluid if loose. It only lets fluid bypass inside the pump. If the screw is slightly loose it will let the fluid out of the trim ram back into the reservoir.
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

Similar Threads

  1. Mercury 60hp 2006 power trim
    By Ivar Johan Hansen in forum Mercury Mariner Outboard Forum
    Replies: 3
    Last Post: 03-29-2015, 05:34 PM
  2. 2002 Mercury 50ELPTO tilt/trim issue
    By Capt.Billl in forum Mercury Mariner Outboard Forum
    Replies: 5
    Last Post: 09-19-2013, 08:49 PM
  3. Mercury XR6 150HP Power tilt/trim issue
    By exciterfan in forum Mercury Mariner Outboard Forum
    Replies: 3
    Last Post: 07-24-2013, 06:42 PM
  4. Mercury 60hp tilt/trim?
    By silvereagle in forum Mercury Mariner Outboard Forum
    Replies: 1
    Last Post: 08-20-2012, 10:45 AM
  5. mercury 2006 60hp four stroke when you use the power trim the motor will stall
    By craig marshall in forum Mercury Mariner Outboard Forum
    Replies: 4
    Last Post: 06-25-2012, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •