Logo
Results 1 to 3 of 3

Thread: 4.3l mercruser

  1. #1

    Default 4.3l mercruser

    My boat runs but will only run while the starter is engaged. I had to gimp it back to the landing. Can someone please help?

  2. #2
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    7,774

    Default Re: 4.3l mercruser

    sounds like you have lost the +12VDC feed from the ignition switch to the + side of the coil.....could be a bad switch, a dirty harness connector (pin or socket), a fuse or circuit breaker in that lead.....

  3. #3
    Join Date
    Sep 2010
    Location
    Jersey Shore
    Posts
    5,482

    Default Re: 4.3l mercruser

    Or the lanyard is pulled.
    Chris
    Dockside Marine Services
    Jersey Shore.
    Mercruiser/Mercury Certified
    Let the insanity begin.

Similar Threads

  1. mercruser overheating
    By John Hoefen in forum Mercruiser Sterndrive Forum
    Replies: 1
    Last Post: 09-02-2012, 09:42 AM
  2. 57 Mercruser 57 LX
    By airdevil85 in forum Mercruiser Sterndrive Archive
    Replies: 0
    Last Post: 08-04-2009, 10:47 PM
  3. 43 mercruser down on power
    By gavo in forum Mercruiser Sterndrive Archive
    Replies: 5
    Last Post: 04-17-2008, 01:13 PM
  4. Mercruser 190hp 37l
    By searay57 in forum Volvo Penta Gas Archive
    Replies: 4
    Last Post: 11-11-2005, 07:40 PM
  5. Omc to mercruser
    By chiefalen in forum OMC Sterndrive and Inboard Forum
    Replies: 0
    Last Post: 12-31-1969, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •