Logo
Results 1 to 2 of 2
  1. #1

    Default Ignition problem

    1988 Cruisers Inc. Model 2660 Vsport with Merc twin 260 HP stern drive
    I have no power to Stbd ignition. Is there a fuse besides the circuit breaker at the engine? I do have power there, and at the large pig-tail on the engine. The main power wire to the ignition switch is dead.

    Thank you

  2. #2
    Join Date
    Jun 2006
    Location
    Spotswood, NJ, USA
    Posts
    3,812

    Default Re: Ignition problem

    Battery connections at battery and engine.
    power starts at the main post of the starter. If there is a square plastic block check the stud for 12v ,you can also check for 12v at the output term on the alt. From there power goes thru the 50 amp CB, test both sides for 12v. Then thru the engine harness plug to the dash. Check the Red wire at the ign switch for 12v then with the key on check for 12v at the purple wire

Similar Threads

  1. Ignition problem I think
    By ship wreck in forum Johnson Evinrude Outboard Forum
    Replies: 3
    Last Post: 07-05-2015, 06:53 PM
  2. ignition problem
    By Barry Coleman in forum Crusader Marine Engine Forum
    Replies: 4
    Last Post: 06-19-2015, 10:42 AM
  3. ignition problem?
    By dons in forum Chrysler Inboard and Sterndrive Forum
    Replies: 2
    Last Post: 08-06-2014, 06:58 AM
  4. ignition problem
    By skeeter11 in forum Mercruiser Sterndrive Forum
    Replies: 9
    Last Post: 06-19-2013, 04:41 PM
  5. DT 15 ignition problem
    By scottwizer in forum Suzuki Outboard Archive
    Replies: 1
    Last Post: 07-25-2008, 01:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •