Logo
Results 1 to 5 of 5
  1. #1

    Default 8.0 KW Westerbeke Fuel pump wont activate

    I have a 8.0 KW Westerbeke gen that the fuel pump will not activate and prime accordingly therefore causing the engine not to start. I have replaced both relays and the Start Stop switch but niether has helped. The reading is less than 1 volt at the pump however, I am able to jump power to the pump and it work.
    Any ideas on what is causing the low to no volts at the fuel pump?

  2. #2

    Default Re: 8.0 KW Westerbeke Fuel pump wont activate

    Failed to mention this gas not diesel.

  3. #3

    Default Re: 8.0 KW Westerbeke Fuel pump wont activate

    Tried the over riding the Over speed switch and that didn't help either.. Anyone have any thoughts?

  4. #4
    Join Date
    May 2015
    Location
    Oregon
    Posts
    70

    Default Re: 8.0 KW Westerbeke Fuel pump wont activate

    You need to check every connection between the fuel pump and the battery including grounds. Problem is probably corrosion in a connector, fuse holder, etc. Make sure you get 12 volts to the relays and switch. Follow the wire where you're getting 1 volt back to it's connection and read there. If you read 12 volts at the other end then either you have a bad wire or a bad ground. And so on...

  5. #5

    Default Re: 8.0 KW Westerbeke Fuel pump wont activate

    Had to call a professional.. turns out there is a bad diode on the overspeed sensor board that needs be replaced as well as an issue between the remote start panel and the generator.. still to be found.

Similar Threads

  1. 1996 502 xli electric fuel pump wont activate
    By lugnutdan in forum Crusader Marine Engine Forum
    Replies: 1
    Last Post: 10-01-2012, 09:10 AM
  2. 5.0 Mercruiser Fuel Pump wont shut off
    By Todd Sabo in forum Mercruiser Sterndrive Forum
    Replies: 7
    Last Post: 09-04-2012, 06:13 PM
  3. Replies: 7
    Last Post: 06-20-2011, 01:46 AM
  4. 30 Mercruiser wont run right after new fuel pump
    By marineman43 in forum Mercruiser Sterndrive Archive
    Replies: 2
    Last Post: 08-10-2009, 11:26 AM
  5. Lift Pump for Westerbeke MAZDA W52 4154
    By Harc Hervey in forum Universal and Westerbeke
    Replies: 0
    Last Post: 06-04-2002, 01:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •