Logo
Get instant online access to repair manuals for your Mercury / Mariner outboard. Online Manuals
MercuryMariner
Order printed Mercury / Mariner service manuals — shipped to your door! Printed Manuals
MercuryMariner
Use engine diagrams to find & order parts for your Mercury / Mariner engine. Engine Diagrams
MercuryMariner
Find parts quickly with Mercury application guides. Quick Parts Guide
MercurySierraCDI
Results 1 to 4 of 4
  1. #1

    Default 2004 mercury 50 efi hot start problem

    Hi i bought a boat thia spring with a 50 hp efi 2004, before buying i had it checked and compression was good an equal on all 4 cylinder. Due to lack of time before the fishing season started i only changed the old gas before using it for the first weekend i decided i will change all 4 spark and motor and lower unit oil during the week.

    I fiah a lot with the trolling motor so i use the big motor to go from spot to spot only.

    First day it ran perfect.

    On the second day by the end of the day everything was working good i was starting the motor without a problem to change spot. But one time i tried to start it and it acted like it was out of fuel it start but its choking start shaking and die if i try to accelerate it can die immediatly or it try to go go to about 3000 rpm and drop if i play with the handle i can keep it alive a little but it will eventualy die without doing any real diatence. What seemed to fix the problem that time was removing the bowl of the fuel filter i heard a psst than put it back and it worked.

    I changed both fuel filter and even the gas tank because there was sont junk in it.

    It didnt solve the problem.

    Cleaned vst it was clear float and needle was ok and a little bit of junk in the pressure regulator screen. Didnt fix

    During the season i had the same problem several time. What i found is every time i start the motor after lunching it start right away no problem. But after i ran WOT to go to a spot if i stop the motor and start fishing with the electric if i try to start it again my problem come back.

    But if after i ran WOT i let it idle around 10 min im good. Its been like that all summer. But this week it didnt seem to work when i turn it off even if it ran idle it start and act like its out of fuel again.

    When it happen now that i do and work every time is i start the motor tank a bowl to not spill to much gas in the water and push on the schredder valve the gas will come out the the motor stop bugging and start to accelerate.

    Easy to do with 2 person but a pain when im alone lol

    The gas that come out is a little bit warm/hot at first for like 1-2 second than is probably at same temp as the tank.

    I need to get a fuel pressure tester but if you guys have any idea or encounter a similar prob.

    I looked a lot on google but couldnt find a similar problem

    Help please i feel like if i get this to a dealer i will get screwed and they will change lots of stuff for nothing lol.

    Thanks
    Frank

  2. #2

    Default Re: 2004 mercury 50 efi hot start problem

    Hi a little update. I hooked a pressure gage on the vst whenni turn the key i have 42 psi when i run it it stay arount 44-42 psi. When i try to restart it and have the problem the fuel pressure go to 30-32 psi and its dropping i have to turn the key 2-3 time to get it to 40 and its still dropping. The primer bulb is not hard andnpumping it has no effect .When i start it it will run till it reach 10 psi then start choking and die. It i put it in idle then i use the drain on the pressure gage to dump fuel the pressure go up and it start to run better then i go put it wot and im good i can put it bavk idle without a problem. Untill i stop it again to fast after wot.

    Next time i will try to look at the voltage on the electric pump.

    But i suspect the low pressure mecanical pump.

    If you guys have any other idea let me know
    Thanks

  3. #3

    Default Re: 2004 mercury 50 efi hot start problem

    Sounds like your either sucking air in your gas lines somewhere or you need to replace you high pressure fuel pump in your vst. The psi in the high pressure fuel pump shouldn't be dropping. When it does your just starving the engine for fuel which is why it's shutting off. I'm not a mechanic but am pretty sure that high pressure pump is the issue. To clear your mind take apart your low pressure pump and check the filter in it could be dirty if you had bad gas or crud in the line. But most like your high pressure pump which is a pretty simple fix if you have already took apart vst before it should be a breeze

  4. #4

    Default Re: 2004 mercury 50 efi hot start problem

    Quote Originally Posted by Jon49k View Post
    Sounds like your either sucking air in your gas lines somewhere or you need to replace you high pressure fuel pump in your vst. The psi in the high pressure fuel pump shouldn't be dropping. When it does your just starving the engine for fuel which is why it's shutting off. I'm not a mechanic but am pretty sure that high pressure pump is the issue. To clear your mind take apart your low pressure pump and check the filter in it could be dirty if you had bad gas or crud in the line. But most like your high pressure pump which is a pretty simple fix if you have already took apart vst before it should be a breeze
    Thanks i will have a look at the hp pump voltage when it does the prob to see if that couldnt be the problem i will also inspect and change the tie wrap on fuel line for crimp to see if it help.

    I dont wanna take my lp pump apart for now cause im still fishing and i cant find the diaphram anyware now i have to buy the whole pump.

Similar Threads

  1. Mercruiser 5.0 MPI 2004 start problem
    By Spudstn in forum Mercruiser Sterndrive Forum
    Replies: 0
    Last Post: 05-29-2014, 05:01 PM
  2. Mercury 9.9HP 2004 remote start will not start in low idle position
    By granpop08 in forum Mercury Mariner Outboard Forum
    Replies: 5
    Last Post: 10-28-2011, 11:54 PM
  3. mercury optimax problem 2004 225 hp
    By mattc14 in forum Mercury Mariner Outboard Forum
    Replies: 2
    Last Post: 06-12-2010, 06:05 PM
  4. 2004 Mercury 50hp 4 Stroke Problem
    By JoshAviation in forum Mercury Mariner Outboard Forum
    Replies: 1
    Last Post: 05-18-2010, 11:37 AM
  5. 2004 Mercury 150 XR6 tilttrim problem
    By starksrob in forum Mercury Mariner Outboard Archive
    Replies: 2
    Last Post: 10-21-2007, 01:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •