Logo
Results 1 to 1 of 1
  1. #1

    Lightbulb Lose spark around 3500rpm

    Does anyone have any thoughts about why my 1988 4.3L runs great from idle to about 3500rpm's . Then it starts missing & bogging. I have replaced the entire ignition system with a pertronix system, coil,cap, rotor,wires. New feul lines and filters, even ran a new hot wire from the coil to ignition switch, no change. I noticed that when it starts missing that the light on my timing light also starts missing, so obviously spark related, right? I'm out of ideas does anyone out there have any suggestions? Spark plugs looked good but I changed them anyway.
    Last edited by Nitrofan16; 09-04-2017 at 08:43 AM.

Similar Threads

  1. Lose spark above 4000rpm
    By Nitrofan16 in forum Chris Craft Engine Forum
    Replies: 12
    Last Post: 09-07-2017, 04:59 PM
  2. F225 2004 engine quits and bogs down at 3500RPM
    By Justmeagain in forum Yamaha Outboard Forum
    Replies: 6
    Last Post: 02-14-2017, 10:24 AM
  3. '74 OMC 120 outdrive has broken the drive shaft twice now while cruising at 3500RPM
    By Craig SacBassman Ness in forum OMC Sterndrive and Inboard Forum
    Replies: 0
    Last Post: 08-24-2012, 12:11 PM
  4. RPM & Speed increased from 3200rpm 18knots 3500rpm 22knots
    By Bob & Sue in forum Mercruiser Sterndrive Forum
    Replies: 15
    Last Post: 11-15-2011, 04:06 PM
  5. 43L sputtering at 3500rpm
    By kevin_boutwell in forum Mercruiser Sterndrive Archive
    Replies: 4
    Last Post: 08-27-2006, 08:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •