Logo
Click for Chrysler parts and manuals!
Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2011
    Location
    New Rochelle, New York, United States
    Posts
    4

    Default Overheating..Stumped

    Hey guys..I have a Chrysler 360 fresh water cooled engine overheating. Just changed the manifolds risers and elbows. Start it up, no leaks but it gets hot real quick up to 220 in seconds. Shut it off real quick, start pulling some coolant hoses to see if is airlocked, sure enough it seemed to be. Seems like all coolant hoses have antifreeze. I Got what seemed to be all the air thru the system, still gets hot, 160 at idle and it keeps going. Here's the odd part. When I give it some more rpms the temp actually goes down quite a bit, and then will go back up again. Nothing is clogged on the raw water side as far as I know, bottom is clean, new hoses to the raw water pump. New impeller last year. Before I changed the manifolds it ran 170 at 2500 rpm. Saw a little steam coming from under each side of both manifolds when I kicked the rpms up. Risers and elbows are cool so it appears the raw water side is good. Mechanic took a quick look said he thinks it's still airlocked, but didn't have much time to look at it as he was going on vacation. Now I can't go on vacation...help!

  2. #2

    Default Re: Overheating..Stumped

    This is probably not the case for you, but I have 318s in my boat, and was experiencing something similar. My gauges were reading wrong. I would start the engine, and it would quickly go to 220 like you say. but If I took an IR thermometer reading of the coolant reservoir, or the heat exchanger inlet, the temps were fine (138 on the tank, and inlet). I changed to thermocouples, which seem to read truer. Also, I found it suspicious that the temp on an engine could rise so quickly from a cold motor. Its probably not your issue, but I would certainly double check around the motor with an independent temp measurement just to make sure.

  3. #3
    Join Date
    Apr 2013
    Location
    Lower Columbia River
    Posts
    80

    Default Re: Overheating..Stumped

    I once had an issue like yours on the first start up of the year. It turned out I had an air leak on the raw water suction side. The hose was clamped tight enough not to leak water, but not tight enough to prevent air from being sucked in. It's a cheap fix: just recheck all your hose clamps between the raw water pickup to the pump.

Similar Threads

  1. Please help!! I'm stumped
    By Sw.anderson in forum Johnson Evinrude Outboard Forum
    Replies: 17
    Last Post: 03-14-2016, 11:20 PM
  2. Stumped
    By SG Tiara in forum Crusader Marine Engine Forum
    Replies: 10
    Last Post: 06-02-2011, 09:43 PM
  3. Stumped by a 5 1/2
    By bill_w in forum Johnson Evinrude Outboard Forum
    Replies: 13
    Last Post: 05-28-2011, 08:41 PM
  4. 90hp 2stroke overheating alarm help Ibm stumped
    By mcatan2468 in forum Yamaha Outboard Archive
    Replies: 6
    Last Post: 01-27-2009, 07:01 PM
  5. Ibm stumped
    By ibnfshn in forum Mercury Mariner Outboard Archive
    Replies: 1
    Last Post: 05-14-2008, 05:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •