Logo
Results 1 to 2 of 2
  1. #1

    Default Water Pump not Pumping and nothing attaching it to the shaft???

    Been awhile I've been out of the boating scene. I have a 198? Johnson Sea horse 20hp. I removed the bottom end because I was getting no water pumping through the motor. The impeller looked ok but I thought it was a little big for the housing and there's nothing tying it into the shaft. The shaft has a flat spot that I have no idea how that works and the impeller has a slot to insert a key but no keyway on the shaft just the flat spot. Can someone explain what's going on here. I plan to buy a new impeller just in case but how in the heck does it rotate with the shaft. Thanks.

    PS Just bought a 2006 Legend All Sport so I'll be back into this site.

  2. #2

    Default Re: Water Pump not Pumping and nothing attaching it to the shaft???

    Buy the new impeller kit and you will get the key that drives the impeller.

Similar Threads

  1. Water pump changed but still not pumping
    By holy1above in forum Mercury Mariner Outboard Forum
    Replies: 2
    Last Post: 06-12-2013, 08:02 AM
  2. Raw water Pump not pumping
    By eldstuff in forum Chrysler Inboard and Sterndrive Forum
    Replies: 20
    Last Post: 05-23-2011, 01:49 PM
  3. Water pump still not pumping
    By wpvaneyssen in forum Chrysler Force Outboard Forum
    Replies: 7
    Last Post: 07-03-2009, 12:25 AM
  4. Help water pump not pumping
    By richard39 in forum Honda Outboard Archive
    Replies: 2
    Last Post: 05-19-2009, 07:06 PM
  5. New water pump but not pumping over 2500RPM
    By brin in forum Johnson Evinrude Outboard Archive
    Replies: 2
    Last Post: 01-02-2008, 01:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •