Logo
Results 1 to 2 of 2
  1. #1

    Default Poor Performance under load

    I have an 87 Supra Ski with the ford windsor 351 in it. Two years ago i started to loose compression so we rebuilt it. It now runs great and the compression is good. When i run it out of the water i get response on RPMs, but when in the water i can only get about 3200 RPMs when i open her up all the way. What could be causing it to preform bad under load?

  2. #2
    Join Date
    Dec 2006
    Location
    Chaumont Bay, N.y., USA
    Posts
    5,142

    Default Re: Poor Performance under load

    Ayuh,.... My 1st guess is bad fuel delivery,....
    Any Grease is Better,... Than No grease at All....

Similar Threads

  1. 86' Evinrude poor performance
    By sroe1984 in forum Johnson Evinrude Outboard Forum
    Replies: 6
    Last Post: 08-18-2014, 11:25 PM
  2. Low/Poor power performance?
    By paulpowell3540 in forum Honda Outboard Forum
    Replies: 15
    Last Post: 03-28-2012, 02:51 AM
  3. Help Please poor performance
    By daddycool in forum Volvo Penta Gas Engine Forum
    Replies: 13
    Last Post: 07-26-2010, 02:19 PM
  4. Poor performance with cowling on
    By mr_pat in forum Johnson Evinrude Outboard Archive
    Replies: 1
    Last Post: 05-02-2009, 12:02 AM
  5. Merc 454 poor performance
    By Mike Ramont in forum Other Gas Inboard Mfgs IO and Sterndrive Questions
    Replies: 4
    Last Post: 09-22-2006, 10:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •