Logo
Click for Suzuki Manuals, Parts and Model Guides!
Results 1 to 6 of 6
  1. #1

    Default DT-5 Ignition issue

    I Have a DT5 (white cowl, red/orange decals Blu leg) wih no spark


    Main coil under fyweel 150 ohm
    triger coil under flywheel 25 ohm

    Main HT coils is sealed


    Any suggestions wht to replace
    Both nder flywheel coils generate AC

    thanks in advance

  2. #2
    Join Date
    Apr 2016
    Location
    barnegat NJ
    Posts
    2,706

    Default Re: DT-5 Ignition issue

    Are the proper plugs installed and gapped properly,Has plug wire been ohmed out also

  3. #3

    Default Re: DT-5 Ignition issue

    Quote Originally Posted by johnnygjr View Post
    Are the proper plugs installed and gapped properly,Has plug wire been ohmed out also
    Thanks Johnnygjr

    I have the original plugs out shorting on chassis to test and HT leads are moulded into twin coil pack, but i will get new plugs :-)

  4. #4
    Join Date
    Apr 2016
    Location
    barnegat NJ
    Posts
    2,706

    Default Re: DT-5 Ignition issue

    Was an open air gap spark test run ,just shorting plugs to block is not a thorough test for sufficient spark

  5. #5

    Default Re: DT-5 Ignition issue

    I've seen a set of inline HT leads with sliding pins for 6 Cyl 12v systems, but wouldn't plugs earthed outside the head be a good start?

    The CDI module is expensive so I want to rule out coils before I get one.

  6. #6
    Join Date
    Apr 2016
    Location
    barnegat NJ
    Posts
    2,706

    Default Re: DT-5 Ignition issue

    An open air gap spark tester can be built with a piece of 1x4 or 1x6 a few finishing nails bent at right angles,alligator clips,solder and wires ala Joe reeves style, Maybe he will respond with the specifics all spelled out. Is battery fully charged? Engine must turn over between 200-300 rpm for stator to produce ignition spark, Hope this helps
    Last edited by johnnygjr; 04-03-2017 at 01:56 AM.

Similar Threads

  1. Ignition issue
    By Reidy in forum Mercruiser Sterndrive Forum
    Replies: 3
    Last Post: 09-27-2016, 12:35 AM
  2. ignition issue
    By a238killfish in forum Johnson Evinrude Outboard Forum
    Replies: 6
    Last Post: 07-26-2016, 06:47 AM
  3. Ignition issue
    By Larry302 in forum Pleasurecraft Marine PCM Forum
    Replies: 11
    Last Post: 11-18-2011, 07:35 AM
  4. 1994 Evinrude 40HP ignition issue? Engine reaches max RPM with ignition off!
    By jeralmac in forum Johnson Evinrude Outboard Forum
    Replies: 13
    Last Post: 07-09-2011, 12:21 PM
  5. Ignition issue
    By mn_native in forum Mercury Mariner Outboard Archive
    Replies: 2
    Last Post: 09-20-2008, 12:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •