Logo
Click for Volvo Penta manuals!
Results 1 to 5 of 5
  1. #1
    Join Date
    May 2009
    Location
    Posts
    55

    Default D3-130 engine electrical fault

    Hi all
    boat has been out all winter. Perfect when I got her out. Put her back in turned on ignition and got the error engine electrical fault service soon.
    started the boat, started fine but will only Rev to 2300rpm (limp mode ?)

    so far I have cleaned all the terminals I can find including earth and positive, checked batteries are fully charged, checked alternator all ok 14.52v disconnected and re connected batteries, checked turbo activator is ok and still no change.
    while it was out during the winter the only work I have done is leg off new bearing and bellows, re bolted down my teleflex top mounted shift and throttle.

    any ideas what I can check next, Volvo can't attend to run diagnostic for 2 week so any ideas would be appreciated.

    regards

  2. #2
    Join Date
    Jun 2008
    Location
    Posts
    544

    Default Re: D3-130 engine electrical fault

    Quote Originally Posted by burkstar View Post
    Hi all
    boat has been out all winter. Perfect when I got her out. Put her back in turned on ignition and got the error engine electrical fault service soon.
    started the boat, started fine but will only Rev to 2300rpm (limp mode ?)

    so far I have cleaned all the terminals I can find including earth and positive, checked batteries are fully charged, checked alternator all ok 14.52v disconnected and re connected batteries, checked turbo activator is ok and still no change.
    while it was out during the winter the only work I have done is leg off new bearing and bellows, re bolted down my teleflex top mounted shift and throttle.

    any ideas what I can check next, Volvo can't attend to run diagnostic for 2 week so any ideas would be appreciated.

    regards
    If you have an outdrive what is the tilt reading? D3's used to have wonderful feature where the often failing trim sensors would put the engine into safe mode (not 2300rpm though) when the sensor failed. Another possibility would be sticky turbo vanes (is the 130hp D3 still turbo?). The D3 uses those wonderful variable vane turbos and the vane system can stick to either over boost or under boost the engine. I suspect that is why so many D3's have grenaded. If your Volvo dealer is like ours they will tell you to replace the very expensive turbo. Reality is a semi competent DIYer can strip the turbo and clean the vanes if that is the issue. Other issue we had was the crank angle sensor failing.

  3. #3
    Join Date
    May 2009
    Location
    Posts
    55

    Default Re: D3-130 engine electrical fault

    Thanks for the reply.
    The trim sensor issue I had that one long ago and have bypassed / disconnected it
    The possible turbo issues make sense and I will start there. Are you saying that if I'm getting 2300rpm out of gear it's not in safe mode? If so it does seem as if it's not boosting.
    The crank sensor I guess is somewhere above the fly wheel. Will have a look at that as well.
    again thank you for the reply.

  4. #4
    Join Date
    May 2009
    Location
    Posts
    55

    Default Re: D3-130 engine electrical fault

    Thank very much Aliboy
    Checked turbo as best I could, checked activator all ok, remembered I replaced boost sensor about 2 years ago and remembered a purchased a spare on the cheap shortly after. Thought it couldn't be that but worth swapping anyway as it a 5 minute just and that was the problem.
    no alarms now and now revs right round to 4.5k

    thanks again for your help.

  5. #5
    Join Date
    Jun 2008
    Location
    Posts
    544

    Default Re: D3-130 engine electrical fault

    Cool. Thanks for the update. Always good to hear what the fixes were.

Similar Threads

  1. Mercruiser 5.7 efi electrical fault
    By Acrook in forum Mercruiser Sterndrive Forum
    Replies: 16
    Last Post: 03-28-2017, 10:41 AM
  2. 2 stroke starting electrical fault help!!!!
    By Rjg30091982 in forum Johnson Evinrude Outboard Forum
    Replies: 9
    Last Post: 07-18-2016, 04:25 PM
  3. 1978 Johnson 25 hp 25R78C Electrical Fault???
    By Tom202 in forum Johnson Evinrude Outboard Forum
    Replies: 1
    Last Post: 11-30-2015, 08:33 AM
  4. Bayliner Capri 1998 Electrical Fault
    By Craic in forum Boat Electrical Systems
    Replies: 1
    Last Post: 01-27-2015, 08:53 PM
  5. Charging electrical fault
    By jeffh in forum Johnson Evinrude Outboard Archive
    Replies: 6
    Last Post: 04-12-2009, 07:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •