Yanmar 1gm on 83 Hunter27 sailboat owned for 4 years
Engine oil good
ran fine when winterized in october
had replaced mixing elbow last year
Penetrating oil worth trying?

Went down to give my 34 year old 1gm a few turns as I have read is good to do during the winter months. I opened up the engine compartment and found that there were 2 inches of rain water underneath. Very strange as I had dried it out in the fall.
Lifted up the decompression lever and went to turn the crank pulley and no movement was to be had.... Crap. Went and got the hand crank handle and put it on and tried again. No movement. Tried a few times. After becoming frustrated put my entire weight on the hand crank but no movement.

Engine had last run in October after a normal season. The last time I started it in the water she was turning slower than usual. I figured this was just low batteries and she started after 6 or 7 tries. A bit of smoke. But not unusual for having not started after a few tries. I was getting low rpms bringing her into the sluesway to haul her out. I thought it was due to a fouled prop. Now I'm wondering if that was the first sign of something being wrong.
I started her up on the hard to run antifreeze through the raw water hose as I always do. She started up normally this time. After she spit pink I shut her down.
Now I can't get the motor to turn. Can't figure out if that moisture in the engine compartment was enough to get the rings frozen in place. Seems strange.
Anyway what do you guys think I should do? Besides have a drink cause it's still winter here in New York. That's a good place to start. I think I'll do that.
Thanks for any advice.