Logo
Results 1 to 5 of 5
  1. #1

    Default Minnkota Edge 55 losing power

    Hi all. I have spent quite a bit of time reading the posts to try and solve my problem that I have. My Edge 55 runs fine for the first 15minutes then starts to lose power quickly. Bought 2 new batteries, ran in parralel, same problem. Tried individually, once one battery seems flat, change over to other battery. Motor then still runs like the battery is dead, barely turning on 5. I have, bought a new charger, bought 2 new batteries, replaced the brushes, replaced the magnet housing, replaced the 5 speed switch, replaced the armature and tested new one on growler. Motor is dry as a bone inside. What next? Checked for the line in prop, checked battery charger. I have not measured the current draw, do not have big enough multimeter and I haven't replaced the momentary switch (only remaining electrical item except for the wiring)

    There is no representative in South Africa where I can send for testing and spares are difficult to come by for quick testing, even the seals has to be ordered in from the US.

    Any help will be appreciated.

    Thanks

    Alfie

  2. #2
    Join Date
    Dec 2015
    Location
    maplevalley WA
    Posts
    3,469

    Default Re: Minnkota Edge 55 losing power

    Sounds like something is getting hot when it happens wherever it is getting hot your close. How long are the wires from the battery to the control? Is there a splice in the wires or are they hard wired straight through? Feel the lug connectors at the battery for heat. Maybe just upgrade the wire size and crimp and solder the lug connectors at the battery and shrink wrap the solder joints and hard wire it all the way to the momentary switch using marine grade tinned wires.
    It takes a nickle to go first class!
    If it aint broke dont fix it!!

  3. #3

    Default Re: Minnkota Edge 55 losing power

    Thanks for the reply. The wiring is standard and not extended, no connections has discoloured due to heat but I will re-check for that. Also ordered small ampmeter to check current. As you say reckon I will recheck every connection for quality and resolder

  4. #4
    Join Date
    Dec 2015
    Location
    maplevalley WA
    Posts
    3,469

    Default Re: Minnkota Edge 55 losing power

    What size batteries are you running? Your motor should pull 50amp max with a recommended 60 amp breaker/fuse at the battery.
    It takes a nickle to go first class!
    If it aint broke dont fix it!!

  5. #5
    Join Date
    Nov 2005
    Location
    Chi West, IL, USA
    Posts
    757

    Default Re: Minnkota Edge 55 losing power

    Found this.............
    Click image for larger version. 

Name:	lowerunit.jpg 
Views:	41 
Size:	99.2 KB 
ID:	14818

Similar Threads

  1. Minn Kota Edge 45 Power concerns
    By gadawg31 in forum Minn Kota Trolling Motors Forum
    Replies: 3
    Last Post: 05-06-2015, 07:03 PM
  2. GM Marine Power 5.7 liter engine pistion hole at edge
    By cahhtravis4 in forum Marine Power Engine Forum
    Replies: 6
    Last Post: 07-07-2014, 12:13 PM
  3. Minn kota 70 thrust edge loss of power
    By jcrenfroe in forum Minn Kota Trolling Motors Forum
    Replies: 3
    Last Post: 05-27-2014, 05:19 PM
  4. 43 TKS losing power
    By mark_mckee in forum Mercruiser Sterndrive Archive
    Replies: 4
    Last Post: 09-03-2009, 06:46 PM
  5. Losing Power
    By mlaco15 in forum Outboard motors archive 2000-2004
    Replies: 1
    Last Post: 08-05-2002, 12:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •