Logo
Results 1 to 13 of 13
  1. #1

    Default Mercruiser 255 has rough idle and stalls

    I have a 1977 Mercruiser 255 (GM) that has a sporadic rough idle and will randomly stall (both in neutral and in gear). If the RPMs are at 1,000 or above I have no issues. The engine accelerates good and has a good throttle response.

    The cap, rotor, and fuel filter were replaced last summer. The plugs and wires were replaced last week. I also cleaned the spark arrestor and sprayed some carb cleaner in the carb and nothing changed.

    This is the port engine and the starboard runs fine. Before I started changing more and swapping parts I thought would ask this forum for some advise. I have a video that I'm going to try to attach.

  2. #2
    Join Date
    Apr 2016
    Location
    barnegat NJ
    Posts
    2,706

    Default Re: Mercruiser 255 has rough idle and stalls

    Do engines run off same fuel tank or separate tanks.possible fuel pump issue on port side,fuel delivery issue,filters checked? Fuel/water separator dumped & inspected? Are u running ethanol? Old fuel in tank on port side? New fuel added to old? Fuel filter changed last summer I would recheck that. Is fuel system all original? fuel lines,carbs,tanks,ETC. Carbs.& pumps could be starting to gum up from ethanol.

  3. #3

    Default Re: Mercruiser 255 has rough idle and stalls

    The gas lines combine into one line and then run back to the engine compartment and then split off again. The lines are copper with a little section of rubber near the engines. I don't know if they are original because I've only had the boat for three years. 3/4 of the gas is from a couple weeks ago and the other is probably a month old. I do add seafoam to my tanks. The stalling has been on and off since last year and is now more frequent and I can hear the engine running less smooth at idle.

  4. #4
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    6,824

    Default Re: Mercruiser 255 has rough idle and stalls

    may want to check the condition of the advance mechanism in the distributor, especially if its original....the springs have a finite lifetime and the mechanical aspects are prone to corrosion if not maintained....

  5. #5

    Default Re: Mercruiser 255 has rough idle and stalls

    Quote Originally Posted by makomark View Post
    may want to check the condition of the advance mechanism in the distributor, especially if its original....the springs have a finite lifetime and the mechanical aspects are prone to corrosion if not maintained....
    I got down to the springs and found that one had a lot less tension than the other. The weight would move about half way before the spring tension took hold while the other was instant. My plan is to search for some new springs tomorrow and reassemble. Thank you for the tip.

  6. #6
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    6,824

    Default Re: Mercruiser 255 has rough idle and stalls

    Don't be surprised if they are NLA....best bet is to take the assembly to a good auto electric shop that has a distributor machine.....the curve should be the factory one when the 'overhaul' is done...

  7. #7

    Default Re: Mercruiser 255 has rough idle and stalls

    I was unable to find a spring. I adjusted the hooks so that the spring would apply some tension to the weight for the entire travel like it does on the other side. After reassembling it, there was no difference. I did notice that the sound is less frequent for the first few minutes when the engine is cold. After about 3 minutes or so, the chug is more frequent but it's still not a consistent pattern. I also changed the in-line fuel filter because I had never done that but it still didn't make any difference.

  8. #8

    Default Re: Mercruiser 255 has rough idle and stalls

    I worked on the boat tonight to try and figure this darn thing out. I put the coil from the good running engine onto my poor running one. After about 15 minutes of running, the engine never stalled and the engine ran smooth. I put the suspect coil back on and the engine stalled twice and it was not running as smooth. I'm going to buy a new coil and hopefully be able to take it out of the slip this weekend.

  9. #9

    Default Re: Mercruiser 255 has rough idle and stalls

    I replaced the coil with a new one and the engine runs better but still has that sporatic chug at idle and did stall on me a couple times. When it stalled, the engine just quit. There was no hesitation or dying out like it ran out of gas. I feel like I'm back at square one. I decided to start at the begining and make sure that cap, points, and rotor were still ok even though they were only a year old. While trying to check the point gap, I noticed that I could rotate the distributor shaft freely by hand maybe 10 or 15. This doesn't seem right to me. I checked my good running engine and I can't move that shaft at all by hand. Does this sound like a bad distibutor? Should I replace this? If I do have to replace, should I move toward an electronic distributor?
    Last edited by mviau; 08-29-2016 at 08:43 AM.

  10. #10
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    6,824

    Default Re: Mercruiser 255 has rough idle and stalls

    I read thru the posts - did you check te points & verify their gap was ok (on the port engine)? that's the first thing to check with that type of distributor

    When you say "rotate the distributor shaft", are you referring to the rotor? if yes, than this is "mostly normal" - the movement of the rotor is provided by the advance mechanism inside the distributor and should be at the low range of what you described....the other engine ("good running") likely has a frozen advance mechanism....checking the timing advance function will let you know one way or the other...

    finally, the 'electronic trigger kits' simplify the maintenance and typically yield better performance...retrofitting them makes sense if the distributor you have is in good mechanical condition - if it isn't, you just throwing away money....just my two cents..

  11. #11
    Join Date
    Apr 2016
    Location
    barnegat NJ
    Posts
    2,706

    Default Re: Mercruiser 255 has rough idle and stalls

    Makomark,that's a 1977, Do they still run with points? Just curious? I thought after1974 everything was electronic.

  12. #12
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    6,824

    Default Re: Mercruiser 255 has rough idle and stalls

    Based on Memory and the few service manuals I have, Mercruiser never marinized a Ford Block with electronic ignition, that I've seen...

    The Op said (post #1) it had new cap & Rotor last year....not new points or condenser....though they get mentioned in Post #9 - my take is the factory setup is still being used....

  13. #13
    Join Date
    Apr 2016
    Location
    barnegat NJ
    Posts
    2,706

    Default Re: Mercruiser 255 has rough idle and stalls

    Missed it in post #9 thanks, johnny

Similar Threads

  1. Mercruiser 5.0 running rough at idle
    By Todd Sabo in forum Mercruiser Sterndrive Forum
    Replies: 8
    Last Post: 07-15-2013, 08:38 PM
  2. 70hp Mercury 1982 blue band rough idle stalls
    By Andy_1602 in forum Mercury Mariner Outboard Forum
    Replies: 44
    Last Post: 07-15-2012, 09:07 PM
  3. Rough Idle Mercruiser 30
    By rcr0729 in forum Mercruiser Sterndrive Archive
    Replies: 4
    Last Post: 08-19-2007, 04:13 PM
  4. Mercruiser V8 350 Bravo one stalls above idle
    By brentgunn in forum Mercruiser Sterndrive Archive
    Replies: 0
    Last Post: 06-09-2006, 01:43 AM
  5. Mercruiser 140 High Idle and Stalls
    By Rod Stewart in forum Mercruiser Sterndrive Archive
    Replies: 0
    Last Post: 12-31-1969, 08:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •