Logo
Click forPleasurecraft Marine parts and manuals!
Results 1 to 4 of 4

Thread: no spark

  1. #1

    Default no spark

    i'm in need of help i'm an owner of a 1975 ski supreme with a ford 351 (pleasure craft) the previous owner changed it over to electric ignition and this is my 2nd year owning . while on the lake last weekend running about 1/3 throttle the boat died and would not restart . while investigating i found out i have no spark i have replaced the cap , rotor, coil, and ignition module and still have no spark but i do have power to coil

  2. #2
    Join Date
    Apr 2016
    Location
    barnegat NJ
    Posts
    2,707

    Default Re: no spark

    Start checking all electronic connections,grounds,positives. Check coil with a dvm.

  3. #3
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    6,758

    Default Re: no spark

    I'd suggest figuring out who's electronic conversion kit was used and getting their troubleshooting guide/call ther tech support dept....

    "ignition module" is somewhat ambiguous.....it may or may not include the trigger mechanism....

    You probably want to make sure the rotor is spinning when the engine is cranking; a broken chain is possible, especially if its original...

  4. #4
    Join Date
    Mar 2009
    Location
    Portland, Oregon,
    Posts
    9,090

    Default Re: no spark

    Quote Originally Posted by makomark View Post
    I'd suggest figuring out who's electronic conversion kit was used and getting their troubleshooting guide/call ther tech support dept....

    "ignition module" is somewhat ambiguous.....it may or may not include the trigger mechanism....

    You probably want to make sure the rotor is spinning when the engine is cranking; a broken chain is possible, especially if its original...
    I'm with Mark. Good suggestions.
    Also agree with John...... check all Positive and Negative connections.

    If by change this is a Pertronix kit , I would toss it and go with a REAL electronic ignition system. Perhaps a VR (variable reluctor) system.

    Keep in mind that the Ford 5.8L ignition distributor is not the same as the 5.0L ignition distributor.


    NOTE:
    Not only look closely at your BASE/Initial advance, but also pay close attention to the Progressive advance and the TA (total advance), and at what RPM it is Full-In!
    See your OEM ignition advance curve data!


    .
    Rick ... aka Ricardo..... AQ series Volvo Penta repair
    Portland, Oregon
    28' SDN F/B w/ twin Volvo Penta 5.7L DP's

    Please... no PMs! Post your questions on the forum.

Similar Threads

  1. Mariner/Yamaha 40hp 1986 thermostat and spark problem, wet spark plugs
    By PatrickMonahan in forum Mercury Mariner Outboard Forum
    Replies: 0
    Last Post: 02-06-2016, 07:49 AM
  2. 1991 Mercury v6 150hp Black Max Spark issues.. too much spark on left side?
    By thord_one in forum Mercury Mariner Outboard Forum
    Replies: 3
    Last Post: 09-25-2014, 09:26 PM
  3. Replies: 1
    Last Post: 06-20-2012, 01:26 PM
  4. 1987 Johnson VRO 140 is not getting any spark or minimal spark to the 3rd cylinder
    By yginesta in forum Johnson Evinrude Outboard Archive
    Replies: 1
    Last Post: 05-23-2007, 01:30 AM
  5. No Spark on Starboard and weak intermittent spark on Port
    By 543svet in forum Volvo Penta Gas Archive
    Replies: 2
    Last Post: 06-22-2006, 06:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •