Logo
Results 1 to 9 of 9
  1. #1
    Join Date
    Jul 2015
    Location
    Poulsbo, WA
    Posts
    7

    Default OMC 115 TurboJet Problems

    1994 Seaswirl Scout w/ OMC Turbojet (115 JEERA)

    ** Number one coil is firing for both port side cylinders, other coils fire only for their respective cylinders.**

    I've rebuilt the VRO2 pump & carbs, replaced plugs, wires, coils, and power pack. Also replaced vent lines, adjusted the throttle linkage, checked timing, and cleaned the flywheel hub.

    This boat will start, idle and run, but only at about 1/4 the max speed. From my dirt bike days, I would say the engine isn't hitting the 'powerband'. It also intermittently coughs at high RPMs. After just the VRO rebuild, the motor would randomly switch between running correctly and running on 2 cylinders. I've managed to get all cylinders to fire, but now it won't run at high speed, not even sporadically like before.

    Stator ohms test indicates 430 when warm, but is below specs at 420 after it cools down. With that exception, the Stator and timing ring pass grounding and resistance checks. I do not have the equipment to perform the running output tests.

    Does anyone know what's left that could cause this firing problem or lack of performance? Stators and timing base are both >$200 new.

  2. #2
    Join Date
    Jul 2015
    Location
    Poulsbo, WA
    Posts
    7

    Default Re: OMC 115 TurboJet Problems

    To clarify the power pack is firing #1 cylinder 2 times per revolution. Once correctly and once 180deg out. All other cylinders are firing correctly.

  3. #3
    Join Date
    Sep 2010
    Posts
    17,829

    Default Re: OMC 115 TurboJet Problems

    And a compression test shows what about this crossflow engine ??

  4. #4
    Join Date
    Jul 2015
    Location
    Poulsbo, WA
    Posts
    7

    Default Re: OMC 115 TurboJet Problems

    Sorry to say , I haven't checked the compression, cause I don't own that tool. I do have a Stevens PVA-1 coming (to go along with my Fluke), so I can conduct the output tests on the stator and timer base.

    I like I said in the original post. The boat ran top speed intermittently after rebuilding the VRO, but would revert to firing on only 2 cylinders. After a new power pack, we have fire on all cylinders, but can't get the boat to go any faster between half and full throttle.

  5. #5
    Join Date
    Apr 2010
    Posts
    4,544

    Default Re: OMC 115 TurboJet Problems

    Do a cylinder drop test on it about 2000 rpm and see what you find. May all so want to squirt some premix fuel in each carb throat once and see what happens.
    Last edited by Boobie; 08-30-2015 at 09:55 PM.

  6. #6
    Join Date
    Apr 2010
    Posts
    4,544

    Default Re: OMC 115 TurboJet Problems

    Do a cylinder drop test on it about 2000 rpm and see what you find.

  7. #7
    Join Date
    Jul 2015
    Location
    Poulsbo, WA
    Posts
    7

    Default Re: OMC 115 TurboJet Problems

    - New stator fixed the double firing of cyl#1, but boat will not operate above 3000rpm under load. 5800 rpm on flush system with no problems, so the ignition problems are fixed.
    - Installed a fuel pressure gauge after fuel pump vacuum checks confirmed operation and integrity of its diaphragms. Also, vacuum checked the pulse limiter line (limiter is new).
    With engine running at almost any RPM, the fuel pressure goes to 4psi while the floats are closed, but once they open it drops to 2psi or less at times.
    - Going to install an electric marine fuel pump (Airtex E8090) and pressure regulator as a booster between the filter and VRO2. Inline fuse and switch on the console as well.
    I'll report back with results.
    Last edited by DEEPCEEV; 08-31-2015 at 04:11 AM. Reason: addition clarification

  8. #8

    Default Re: OMC 115 TurboJet Problems

    I have a Boston whaler rage, the problem what I have with this is when I turn on the engine and connect the hose, the water don’t come out, somebody can help me please I would appreciate

  9. #9

    Default Re: OMC 115 TurboJet Problems

    Should upgrade to crank driven raw water pump.

Similar Threads

  1. 94 OMC 90hp Turbojet cooling ?
    By n36511 in forum Johnson Evinrude Outboard Forum
    Replies: 12
    Last Post: 10-19-2019, 08:54 PM
  2. OMC 90 Turbojet exhaust temp
    By n36511 in forum Johnson Evinrude Outboard Forum
    Replies: 4
    Last Post: 03-02-2012, 10:06 AM
  3. 94 OMC 90 turbojet starting issues
    By n36511 in forum Johnson Evinrude Outboard Forum
    Replies: 8
    Last Post: 03-01-2012, 10:30 PM
  4. Turbojet query
    By jafa39 in forum Johnson Evinrude Outboard Forum
    Replies: 6
    Last Post: 12-25-2009, 08:21 PM
  5. 115 turbojet will not run
    By rusty kirchen in forum Johnson Evinrude Outboard Archive
    Replies: 5
    Last Post: 09-03-2008, 06:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •