Hey Guys (and Gals) I have a 2008 MotorGuide Pro Series foot-operated 12 volt trolling motor that will not shut off. It is model# 950010200 and serial# 9B397606. It came on a boat I bought last year but have never had on the water. For a few weeks last year it was outside exposed to the elements. It worked fine when I bought it and I didn't discover this issue until this week. It has a 3 position toggle switch on the side of the pedal that switches between constant on, temporary on if you push the toe switch on top off the pedal and the final (c) position is off unless you hit the toe pedal which is supposed to give high speed regardless of where the dial speed knob is positioned. The motor runs continuously in all 3 toggle positions but does increase to full speed in the (c) position if the toe button is pressed. This leads me to believe that at least the toe activated button is working properly. The rotary dial speed selector switch does change the speed that the motor is running at but even in the off position the motor continues to run. I was told by a MotorGuide technician to disconnect the blue, red and yellow wires that lead down to the lower unit and see if it still runs. If it is still running then there is a problem with the lower unit. If it is not running then the problem is in the foot control. From the wiring diagrams I have seen by disconnecting those 3 wires there is no chance of power even getting to the lower unit so what good is that test? Any advice is Greatly appreciated! Thanks in advance.