Logo
Results 1 to 2 of 2
  1. #1

    Question Issues with slow Idle backfire on 1982 15 HP Sea King

    Just found all the numbers to the motor! Purchased this with a Gamefisher last summer, used it once and it kept dying out in the lake so gave up and stored it till now. I put in new fuel, oil checked plugs. I can get the motor started now, but when I try to slow it down to engage the prop it seems to POP a few times and then stalls out. I can run it at a medium speed while not engaged but only have been able to get prop engaged once today then when I took it down to a slow speed it crapped out on me. Really would like to get this motor running because I would like to use it OR Sell this one with my old SeaGull and get a electric trolling motor. Also in on photo below it looks like there may be some part missing! There are 2 screw holes above in the photo and a round opening in the lower section of the photo! Anybody have an idea on what might go there?
    Click image for larger version. 

Name:	motor-4.jpg 
Views:	619 
Size:	82.7 KB 
ID:	9818

    Here are the specs, also would like to locate a User MANUAL!
    wards Sea King 15 HP-Model # VWB52119C, 1982 yr Chrysler Ser # G392078

    Thanks in advance
    Click image for larger version. 

Name:	motor-6.jpg 
Views:	165 
Size:	58.3 KB 
ID:	9817
    Ken Dreger

  2. #2

    Default Re: Issues with slow Idle backfire on 1982 15 HP Sea King

    Quote Originally Posted by Ken Dreger View Post
    Just found all the numbers to the motor! Purchased this with a Gamefisher last summer, used it once and it kept dying out in the lake so gave up and stored it till now. I put in new fuel, oil checked plugs. I can get the motor started now, but when I try to slow it down to engage the prop it seems to POP a few times and then stalls out. I can run it at a medium speed while not engaged but only have been able to get prop engaged once today then when I took it down to a slow speed it crapped out on me. Really would like to get this motor running because I would like to use it OR Sell this one with my old SeaGull and get a electric trolling motor. Also in on photo below it looks like there may be some part missing! There are 2 screw holes above in the photo and a round opening in the lower section of the photo! Anybody have an idea on what might go there?
    Click image for larger version. 

Name:	motor-4.jpg 
Views:	619 
Size:	82.7 KB 
ID:	9818

    Here are the specs, also would like to locate a User MANUAL!
    wards Sea King 15 HP-Model # VWB52119C, 1982 yr Chrysler Ser # G392078

    Thanks in advance
    Click image for larger version. 

Name:	motor-6.jpg 
Views:	165 
Size:	58.3 KB 
ID:	9817
    i have one a year earlier. youre missing the pull start assembly. cant help with the rest. remove the carb and clean it it you have good spark

Similar Threads

  1. 1989 evinrude xp 200 coolant and backfire at idle
    By johnsii97 in forum Johnson Evinrude Outboard Forum
    Replies: 22
    Last Post: 08-17-2014, 08:51 PM
  2. 1982, 90HP Johnson won't stay running at idle or slow speeds.
    By cack63 in forum Johnson Evinrude Outboard Forum
    Replies: 9
    Last Post: 05-24-2013, 12:21 PM
  3. 2008 BF50 efi backfire from idle to 4500rpm
    By iris in forum Honda Outboard Forum
    Replies: 2
    Last Post: 08-16-2012, 05:04 AM
  4. omc king cobra 5.8l efi backfire underload and loss of power Help!!
    By damien in forum OMC Sterndrive and Inboard Forum
    Replies: 5
    Last Post: 06-20-2012, 02:14 PM
  5. Engine stalls when I slow to idle or go from idle to neutral
    By vpamateur in forum Volvo Penta Gas Engine Forum
    Replies: 0
    Last Post: 03-19-2012, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •