Logo
Click for Perkins manuals!
Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2009
    Location
    forked river , n.j., usa
    Posts
    100

    Default Perkins 165 HP oil psi

    I put new sender on 20psi at start up drops down to 8/10 psi after running I got a new gauge and sender that were supposed to match same thing happened I got another sender from Foley in Ma. That didn't help either I put a snap on test gauge on 38psi at start up and held 30 psi can't figure out why these senders aren't working Thanks

  2. #2

    Default Re: Perkins 165 HP oil psi

    Quote Originally Posted by goody View Post
    I put a snap on test gauge on 38psi at start up and held 30 psi can't figure out why these senders aren't working Thanks
    One thing I can tell you is that the motor should be running at 50 to 60 PSI so you have more trouble than just the guages . Is it tired and worn ? Is the line inside from oil pump to filter and thence to distribution loose or broken in some way ?

    Hate to say it but you may have to get the sump off and have a look .
    Maybe you have the wrong grade Oil? Try a thicker oil temporarily even to the point of adding 1/2 gearbox oil to thicken it up and see what that does.

Similar Threads

  1. Perkins 165 HP id #
    By goody in forum Perkins
    Replies: 1
    Last Post: 07-26-2014, 09:47 PM
  2. Perkins 165 HP
    By goody in forum Perkins
    Replies: 0
    Last Post: 07-23-2014, 10:37 PM
  3. Perkins 165 HP
    By goody in forum Perkins
    Replies: 0
    Last Post: 07-16-2014, 05:56 AM
  4. Perkins 6-354 oil pan
    By uglydukwling in forum Perkins
    Replies: 0
    Last Post: 03-04-2014, 05:57 PM
  5. perkins 6 354
    By frantasy in forum Perkins
    Replies: 1
    Last Post: 02-29-2012, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •