Logo
Results 1 to 2 of 2
  1. #1

    Default 15 hp gamefisher (force) running problems

    I found and bought this 15 hp M# 225-581503/S# 11387 for $100. I have put a new fuel pump diaphragm kit, head gasket, fuel lines, fuel float bowl and bowl gasket. It is hard to start, it takes about 25 pulls, sometime more to start. It won't idle but as long as I keep tiller handle as far as I can go to the left it will run. Once I put into gear, it will run just fine as long as I don't go back to idle. My question is what is going on with it? Is it losing the prime, getting air or is it the idle screw. I have adjusted the idle screw to fully close to fully open and it want do anything to the idle of the engine. I'm not sure what else to do to it, except get a complete carburetor kit to rebuild it. Anybody have any ideas.

  2. #2

    Default Re: 15 hp gamefisher (force) running problems

    Thats your best bet the carb. needs cleaning for sure. the adjustment on the screw should be 1.25 turns.

Similar Threads

  1. 9.9 HP gamefisher/Force ingintion problem
    By Floatation Device in forum Chrysler Force Outboard Forum
    Replies: 1
    Last Post: 06-08-2014, 09:54 AM
  2. **Need coil for 5hp gamefisher/force**
    By skizman in forum Chrysler Force Outboard Forum
    Replies: 0
    Last Post: 03-24-2013, 09:58 AM
  3. To all that have worked on Gamefisher Force ignition systems
    By tom357mag in forum Gamefisher Outboards
    Replies: 2
    Last Post: 09-28-2008, 10:05 PM
  4. Spark plug gap 1989 15 hp gamefisher Force
    By tom357mag in forum Gamefisher Outboards
    Replies: 1
    Last Post: 09-23-2008, 11:28 PM
  5. 97 Force 99 gamefisher No Spark
    By slim_jim in forum Chrysler Force Outboard Forum
    Replies: 4
    Last Post: 09-08-2008, 11:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •