Logo
Results 1 to 5 of 5
  1. #1

    Default gamefisher 15. lacks power

    have a 94 gamefisher 15. 225.581496 starts and runs on first pull. runs smooth but will not rev. Seems to use too much fuel. had a tach on it only got 3800 rpm. dont think its over proped. could my carb be dirty? any help would be appriciated. thanks

  2. #2

    Default Re: gamefisher 15. lacks power

    You should start by testing the compression. PSI should be within 10% of each other in both cylinders.

    Then; test spark. Should jump at least 1/4" gap.....7/16" if you have electronic ignition. Don't just look at the spark plug gap; use a spark tester. They cost about $7.00 at auto-parts stores.

    Could the carb be dirty? It sure could! Clean the main jet and the needle and seat areas at a minimum...and check float level.

    I like those motors. That model is way better than most of Sear's offerings over the years.

  3. #3

    Default Re: gamefisher 15. lacks power

    Quote Originally Posted by Seakaye12 View Post
    You should start by testing the compression. PSI should be within 10% of each other in both cylinders.

    Then; test spark. Should jump at least 1/4" gap.....7/16" if you have electronic ignition. Don't just look at the spark plug gap; use a spark tester. They cost about $7.00 at auto-parts stores.

    Could the carb be dirty? It sure could! Clean the main jet and the needle and seat areas at a minimum...and check float level.

    I like those motors. That model is way better than most of Sear's offerings over the years.
    compression is good. cleaned carb. it was already clean. have to get a spark tester. heard th ignition modules go bad on these. know i have spark. maybe not strong enough. motor runs so smooth jus no rpm. thanks for your reply

  4. #4

    Default Re: gamefisher 15. lacks power

    Have you checked to see that the carb butterfly is completely horizontal when you advance the throttle to WOT?

    Also...check the mag plate and it's it's linkage to be sure that it's advancing all the way....

  5. #5

    Default Re: gamefisher 15. lacks power

    Quote Originally Posted by Seakaye12 View Post
    Have you checked to see that the carb butterfly is completely horizontal when you advance the throttle to WOT?

    Also...check the mag plate and it's it's linkage to be sure that it's advancing all the way....
    all seems to be working properly. heard lots about bad coils on these motors. not sure how to test them. thanks

Similar Threads

  1. 1989 15 HP lacks power
    By Peterbeaudry in forum Johnson Evinrude Outboard Forum
    Replies: 4
    Last Post: 03-29-2011, 05:40 PM
  2. LM318 Lacks top end power
    By Dennis B. in forum Chrysler Inboard and Sterndrive Archive
    Replies: 10
    Last Post: 09-08-2007, 08:02 AM
  3. Lacks power
    By paulbip in forum Johnson Evinrude Outboard Archive
    Replies: 9
    Last Post: 07-05-2007, 02:25 PM
  4. 88b Merc 135 lacks power
    By the_woodwright in forum Mercury Mariner Outboard Archive
    Replies: 1
    Last Post: 02-24-2007, 04:50 PM
  5. 30 4 cylinder lacks power
    By cj5732 in forum Other Gas Inboard Mfgs IO and Sterndrive Questions
    Replies: 7
    Last Post: 03-06-2006, 08:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •