Logo
Click for Volvo Penta parts and manuals!
Results 1 to 6 of 6
  1. #1

    Default DP-C1 power trim electrical problem

    I have a 1994 VP 5.7GL with a DP-C1 drive. It's a good combination and with the help of my Sealoc manual (sometimes) and this great forum I have changed the PDS, U-joints etc. etc. Anyway, the power trim UP recently stopped working unless I press both trim & tilt buttons together. Down works fine. I have checked the T/T switches, checked the wires, swapped the 2 relays in the dash, swapped the 2 relays on the T/T motor and can't find the problem. I tried to trace all the wires but got lost in a maze. Most of the wires from the 2 relays, trim gauge, and T/T switches go into a small black plastic box ( control box ? ). I'm thinking this black box might be the problem but it is too expensive to replace just on a hunch. Has anyone had this problem? Any info/advice would be appreciated. Many thanks!

  2. #2

    Default Re: DP-C1 power trim electrical problem

    It started working- not sure why. I found some more connections that I cleaned and turned some screws on that black box that looks like a hockey puck- only square with lots of wires. One screw sets the position of the needle on the trim gauge and the other seems to adj. where the trim stops and the tilt begins. Don't know if it was the connections or messing with the hockey puck but it started working and life is good!

  3. #3
    Join Date
    Mar 2009
    Location
    Portland, Oregon,
    Posts
    9,092

    Default Re: DP-C1 power trim electrical problem

    Glad that you got it working. Also glad to hear that you replaced the PDS bearing.
    You can't even begin to imagine the damage that a failed PDS bearing can cause!

    I just did one yesterday.
    The shop who previously worked on this boat (actually a new OMC Cobra-to-V/P DP-C1 conversion in '05) installed an "open" 6206 bearing.
    As you know, this flywheel cover does not offer a grease port for this bearing... so we must use a sealed bearing.

    You new PDS bearing will go for another 400 hours.

    .
    Rick ... aka Ricardo..... AQ series Volvo Penta repair
    Portland, Oregon
    28' SDN F/B w/ twin Volvo Penta 5.7L DP's

    Please... no PMs! Post your questions on the forum.

  4. #4

    Default Re: DP-C1 power trim electrical problem

    When I did the PDS bearing last year the one that came out was an open bearing and I'm sure it was original factory installation. My FC is VP white?/green with no zerk. The cavity between the 2 seals was still packed with grease but the bearing was dry. Even the new bearing I ordered from the VP website was open. Glad to hear I did the right thing by taking it to my local NAPA store and getting a sealed one.

  5. #5
    Join Date
    Mar 2009
    Location
    Portland, Oregon,
    Posts
    9,092

    Default Re: DP-C1 power trim electrical problem

    Quote Originally Posted by tarheeltom View Post
    1. When I did the PDS bearing last year the one that came out was an open bearing and I'm sure it was original factory installation.
    2. My FC is VP white?/green with no zerk. The cavity between the 2 seals was still packed with grease but the bearing was dry. Even the new bearing I ordered from the VP website was open.
    3. Glad to hear I did the right thing by taking it to my local NAPA store and getting a sealed one.

    1. That is strange!
    2. Your FC should have been the charcoal gray color. The red 1 pc FC hasn't been used since the change in model number designation. And if memory serves me, the Borg Warner FC w/ the B/W- VP PDS adapter housing hasn't been used since the late 70's... early 80's.
    3. If single bearing...... Yes!
    Rick ... aka Ricardo..... AQ series Volvo Penta repair
    Portland, Oregon
    28' SDN F/B w/ twin Volvo Penta 5.7L DP's

    Please... no PMs! Post your questions on the forum.

  6. #6

    Default Re: DP-C1 power trim electrical problem

    You are right- the FC is charcoal gray. I guess I was thinking about the part of the transom shield inside the boat that is pale green. Had to go look at it- the memory isn't what it used to be. Thanks again

Similar Threads

  1. Power trim problem
    By MC2044 in forum Mercury Mariner Outboard Forum
    Replies: 1
    Last Post: 09-05-2011, 09:15 AM
  2. power trim problem
    By tojohnson in forum Honda Outboard Forum
    Replies: 2
    Last Post: 06-29-2010, 11:51 AM
  3. Power Trim Electrical Issue 2002 50 hp
    By mark45053 in forum Mercury Mariner Outboard Forum
    Replies: 4
    Last Post: 04-12-2010, 12:50 PM
  4. 1991 43L Mercruiser No electrical power except trim
    By jimbo66 in forum Mercruiser Sterndrive Archive
    Replies: 1
    Last Post: 06-29-2008, 08:14 PM
  5. Power trim problem
    By duddy in forum Johnson Evinrude Outboard Archive
    Replies: 1
    Last Post: 09-20-2006, 03:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •