MarineEngine.com - Your online store for all types of marine engines and boat parts.
PHONE ORDERS
Monday - Friday
9:00 AM - 5:00 PM EST
Click for TOLL-FREE Number
Online Checkout
Special $9.95 Flat Rate Shipping
(800) 209-9624 | Home | Contact | Shipping | Returns | Cart View your shopping cart.
Part Number Search
Shop by engine/drive part number.
Original & matching parts for sale.
Manuals & Accessories
Shop by description, item number
or manufacturer's model number.
Boat Repair Forum Boat Repair Forum   Boat Video Gallery Video Gallery
   
Get instant online access to repair manuals for your Mercury / Mariner outboard. Online Manuals
MercuryMariner
Order printed Mercury / Mariner service manuals — shipped to your door! Printed Manuals
MercuryMariner
Use engine diagrams to find & order parts for your Mercury / Mariner engine. Engine Diagrams
MercuryMariner
Find parts quickly with Mercury application guides. Quick Parts Guide
MercurySierraCDI
Results 1 to 4 of 4
  1. #1

    Default power trim not working

    Does anyone know why the power trim is stuck in the up position? I have a 90 model mariner 50 hp. I don't know anything about this boat because i just bought it and carried it to the water todaY. The power trim worked while in water. and prior to puting in the water. i raised the motor using trim to take out of the water and now it will not work. Does anyone have any ideal what could be the problem? the button will click in the up and down position but no movement to the trim at all. please help! Totally clueless. <br><br>thanks for your input...

  2. #2
    Join Date
    Aug 2006
    Location
    SW Ohio, USA
    Posts
    10,328

    Default Re: power trim not working

    Check the battery's charge level and the power trim wire connections for corrosion.
    Fix minor things (replace wear items for preventative maintenance.) that cause major problems before they break.

  3. #3
    Join Date
    Jan 2012
    Location
    Giessendam, Zuid-Holland, Netherlands, Netherlands
    Posts
    102

    Default Re: power trim not working

    Does the trimmotor run when you push the button (up of down).

    When it runs, push the down button and ask somebody to push the engine down (on the same time), most probably it will work fine now, and try to not tilt the motor to the maximum.

  4. #4
    Join Date
    Mar 2011
    Location
    northern IL.
    Posts
    77

    Default Re: power trim not working

    Have you checked the transom lock to make sure that the motor isn't locked in the up position? Look on the transom brackets for a small leaver or push pin. It might have gottem moved without knowing it. It is used when working on the LU or trim system mainly.
    Welcome to the world of Boating and Headakes,
    Oldman570

Similar Threads

  1. power trim not working
    By nuboater99 in forum Mercury Mariner Outboard Forum
    Replies: 2
    Last Post: 02-04-2012, 01:52 AM
  2. Power Trim not working
    By canaltrash in forum Mercruiser Sterndrive Forum
    Replies: 22
    Last Post: 08-09-2010, 12:11 AM
  3. 90Hp Johnson 1981 Power tilt trim not working
    By ed_in_va in forum Johnson Evinrude Outboard Archive
    Replies: 9
    Last Post: 05-01-2009, 08:25 PM
  4. Power trim and tilt just clicksnot working
    By Brian Siemon in forum Mercury Mariner Outboard Archive
    Replies: 5
    Last Post: 01-16-2007, 09:07 PM
  5. Trim not working
    By thunder8905 in forum OMC Sterndrive and Inboard Archive
    Replies: 1
    Last Post: 05-24-2006, 11:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •