MarineEngine.com - Your online store for all types of marine engines and boat parts.
PHONE ORDERS
Monday - Friday
9:00 AM - 5:00 PM EST
Click for TOLL-FREE Number
Online Checkout
Special $9.95 Flat Rate Shipping
(800) 209-9624 | Home | Contact | Shipping | Returns | Cart View your shopping cart.
Part Number Search
Shop by engine/drive part number.
Original & matching parts for sale.
Manuals & Accessories
Shop by description, item number
or manufacturer's model number.
Boat Repair Forum Boat Repair Forum   Boat Video Gallery Video Gallery
   
Get instant online access to repair manuals for your Mercury / Mariner outboard. Online Manuals
MercuryMariner
Order printed Mercury / Mariner service manuals — shipped to your door! Printed Manuals
MercuryMariner
Use engine diagrams to find & order parts for your Mercury / Mariner engine. Engine Diagrams
MercuryMariner
Find parts quickly with Mercury application guides. Quick Parts Guide
MercurySierraCDI
Results 1 to 16 of 16
  1. #1

    Default 1983 Mercury 70 HP stalls under load

    I have a 1983 Mercury 70 HP that stalls under load. It is getting very good spark at plugs. When I pull number 3 wire it has no effect on how the engine runs. When removal of plug there is a wetness on plug.Engine runs rough. Why in the number 3 piston not fireing internaly? Can someone help me?

    Thanks,

    Emerson2
    Last edited by Emerson2; 10-26-2010 at 03:13 PM.

  2. #2
    Join Date
    Sep 2010
    Location
    ontario
    Posts
    9,845

    Default Re: 1983 Mercury 70 HP stalls under load

    What is the compression on the # 3 cylinder ??------------Have you checked the reed valves for # 3 crankcase.---------------------Have you checked the lower carburetor for a blockage ( no fuel to # 3 )

  3. #3

    Default Re: 1983 Mercury 70 HP stalls under load

    I now am not sure if it is cylinder1 or cylinder 3 but it is the bottom cylinder. Yes I did check the compression and it is top cylinder is 141, middle cylinder is 149, and bottom cylinder is 141. I have not checked the reed valves. not sure where they are.

  4. #4
    Join Date
    Sep 2010
    Location
    ontario
    Posts
    9,845

    Default Re: 1983 Mercury 70 HP stalls under load

    The top carburetor feeds the top ( #1 ) and also #2------------The bottom carburetor feeds #3 and also #2 ------------So there may be something wrong in the bottom carburetor.-------------------The reed valves are internal around the crankshaft.-They can be inspected when carburetor is removed.

  5. #5

    Default Re: 1983 Mercury 70 HP stalls under load

    Well I got time to work on my engine. Removed carbs, removed the bowls , checked everything and they are clean and look good. I did find the reed valves. They look good, but what I am I looking for? I did order a new stator because the insulation on the wires have started break and wires have corroded and starting to break. Where do I go from here?

  6. #6
    Join Date
    Sep 2010
    Location
    ontario
    Posts
    9,845

    Default Re: 1983 Mercury 70 HP stalls under load

    What gap will the ignition system fire on #3----7/16" or better???

  7. #7

    Default Re: 1983 Mercury 70 HP stalls under load

    I cannot check gap due to type of plugs. You were referring to spark plugs ??
    Thanks
    Emerson

  8. #8
    Join Date
    Sep 2010
    Location
    ontario
    Posts
    9,845

    Default Re: 1983 Mercury 70 HP stalls under load

    Laying plugs on the block is---------- NOT A GOOD TEST FOR SPARK------------------See/test what gap it can jump!!

  9. #9

    Default Re: 1983 Mercury 70 HP stalls under load

    Tomorrow I will put some of the parts back so I can check the spark with an ajustable spark tester. I will let you know what I find.
    Thanks,

    Emerson

  10. #10
    Join Date
    Sep 2003
    Location
    New Tripoli, PA, USA!
    Posts
    12,648

    Default Re: 1983 Mercury 70 HP stalls under load

    I suspect you have a bad coil. If # 2 runs okay, then there's nothing wrong with the bottom carb.

    Jeff

    PS: I run one of those myself and like them (which is not what most people think of them!)

  11. #11
    Join Date
    Sep 2010
    Location
    ontario
    Posts
    9,845

    Default Re: 1983 Mercury 70 HP stalls under load

    #2 gets fuel from the top carburetor and the bottom carburetor?

  12. #12
    Join Date
    Sep 2003
    Location
    New Tripoli, PA, USA!
    Posts
    12,648

    Default Re: 1983 Mercury 70 HP stalls under load

    Correct.

    Jeff

  13. #13
    Join Date
    Jul 2010
    Location
    Skiatook, Ok.
    Posts
    17

    Default Re: 1983 Mercury 70 HP stalls under load

    The one and only motor of this type I ever saw had broken reeds and was doing the same thing. You have to split the cases to fix it . also you can't see all of them without spitting the cases.

  14. #14
    Join Date
    Jun 2008
    Location
    Malden, MA,
    Posts
    283

    Default Re: 1983 Mercury 70 HP stalls under load

    you can also get a spark tester, plugs in line between your plug wire and your sparkplug, it will light up if you are getting good spark.

  15. #15

    Default Re: 1983 Mercury 70 HP stalls under load

    racerone

    I thought that I sent this yesterday. Well I will try thios again. I put this motor back together enough to start. To my surprise it started and ran very well. I did check the spark gap with a spark tester. Opened the gap to about 1/2 in. and I have a very heavy dark blue spark on all three plugs. Not sure what I did but it seems to run great. Maybe the float valve was stuck or dirt in carb. Next i will put it all back together an d try it on the lake. I will make final adjustment to carbs there. Do you think I should do anything else.

    Thanks for your help and support

    Emerson2

  16. #16
    Join Date
    Sep 2003
    Location
    New Tripoli, PA, USA!
    Posts
    12,648

    Default Re: 1983 Mercury 70 HP stalls under load

    You may have fixed the problem when you cleaned out the carbs. That's what cured mine; the idle circuit of the top carb was partially plugged. You can hear the motor sag like crazy at the end of the video below.

    Jeff

    http://www.youtube.com/watch?v=1oCSXMSWUEU
    Last edited by fastjeff; 11-05-2010 at 08:12 AM.

Similar Threads

  1. DT75 stalls under load
    By mgn_wp in forum Suzuki Outboard Archive
    Replies: 12
    Last Post: 10-31-2008, 03:12 AM
  2. Mercury 6HP 4 stroke stalls under load
    By davedylan in forum Mercury Mariner Outboard Archive
    Replies: 3
    Last Post: 06-26-2008, 09:32 PM
  3. HELP my 35hp mercury is sluggish and stalls under load
    By greazyt in forum Mercury Mariner Outboard Archive
    Replies: 6
    Last Post: 06-02-2008, 04:51 PM
  4. Stalls under load
    By dawgs in forum Mercruiser Sterndrive Archive
    Replies: 6
    Last Post: 07-19-2007, 10:59 PM
  5. 1978 90hp Mercury inline 6 stalls with load on it
    By bradccool in forum Mercury Mariner Outboard Archive
    Replies: 8
    Last Post: 05-11-2007, 12:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •