Logo
Results 1 to 2 of 2
  1. #1

    Default Rusty starter motor (flywheel?) BTA5.9 M-2

    Had starter rebuilt and several hours on engines later, the same problem exists. The gear that extends to the flywheel is completely rusted. How could this happen again so soon? We found and repaired a leak in the riser last time. My mechanic says its rust powder in the bottom of the bellhousing. Any thoughts??

  2. #2

    Default Re: Rusty starter motor (flywheel?) BTA5.9 M-2

    Does anyone have a reply to this? I'm experiencing the same thing. And, how does water get inside the bell housing?

Similar Threads

  1. Starter to Flywheel Engagement 1997 5.7
    By troym in forum Mercruiser Sterndrive Forum
    Replies: 25
    Last Post: 04-12-2010, 07:01 AM
  2. Starter jamming on flywheel
    By kmiddleton57 in forum Mercury Mariner Outboard Forum
    Replies: 7
    Last Post: 03-31-2010, 01:19 PM
  3. Johnson 1989 110HP Starter Motor Not Engaging Flywheel
    By mr_johnson in forum Johnson Evinrude Outboard Archive
    Replies: 14
    Last Post: 11-02-2008, 03:06 PM
  4. Starter wont stay engaged to flywheel
    By jcneptu in forum Archive 2003-2007
    Replies: 2
    Last Post: 05-21-2004, 05:10 PM
  5. Johnson 130 Starter Flywheel Problem
    By MB in forum Outboard motors archive 2000-2004
    Replies: 5
    Last Post: 07-05-2002, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •