Logo
Results 1 to 9 of 9
  1. #1
    Join Date
    Dec 2009
    Location
    Beaufort, SC, USA
    Posts
    4

    Default I have a 97 150hp fast strike.

    I have a 97 150hp fast strike. I took boat out last weekend for the first time in 2 months. I let it run for about 10 min. at dock then took off and it stalled out. Got it started and stalled again.Did this three times same result while sitting at dock. I had to pump the ball everytime to start.Not sure where to start looking for problem.I did run the motor about month ago to cycle staybil through system and has 3/4 tank of fuel while it sat in garage.

  2. #2
    Join Date
    Feb 2009
    Location
    perth, wa, Australia
    Posts
    956

    Default When you say you had to pump t

    When you say you had to pump the ball how many pumps befor it went hard.

    Replace the water sep filter and blow through the fuel lines back to the tank.

    The carbies most probaly will require striping and cleaning out.

  3. #3
    Join Date
    May 2008
    Location
    Kent, the garden of England, UK
    Posts
    1,199

    Default A bit suspicious that you had

    A bit suspicious that you had to pump the ball after running.

    Check tank venting and fuel line and pick up from tank for obstructions

    Check fuel line for air ingress esp connections at engine and tank.

    Consider a defective fuel pump.

    Will it run if you keep gently pumping the ball?

    If it falters and dies as soon as you open the throttle most likely the carbs require cleaning. If it dies slowly then one of the above problems with the fuel line or pump.

  4. #4
    Join Date
    Dec 2009
    Location
    Beaufort, SC, USA
    Posts
    4

    Default I had to pump ball about 6-8 t

    I had to pump ball about 6-8 times to fill it up. It was soft after it stalled out.I have noticed that in the past the ball would be soft when I start it several times while on the water for the day. I do not have a water sep filter installed yet. Thanks for the responces.

  5. #5
    Join Date
    Feb 2009
    Location
    perth, wa, Australia
    Posts
    956

    Default "Once you pump the primer bulb

    "Once you pump the primer bulb and its hard, it will not stay hard while the engine is running as the fuel pump sucks fuel there is a vacume in the fuel line and bulb and it will take about one pump to make it go hard again. However if its taking 6-8 you have a fuel pump problem"

  6. #6
    Join Date
    Dec 2009
    Location
    Beaufort, SC, USA
    Posts
    4

    Default Thats not what I wanted to her

    Thats not what I wanted to here but I know that might be the problem. I'm going to clean the lines out and make sure all the fittings are tight and clean the carbs. Is there a kit to rebuild fuel pump or buy new? If rebuild kit offered where can i find a good diagram online? Thanks for the help.

  7. #7
    Join Date
    Feb 2009
    Location
    perth, wa, Australia
    Posts
    956

    Default I would not rebuild the vro pu

    I would not rebuild the vro pump as the housings warp etc...I would put the boat back in the water with a mate and get them to pump the primer bulb continuously and see if the engine runs ok. If it still stalls while manually priming there will be some blockages in the carbies

  8. #8
    Join Date
    Dec 2009
    Location
    Beaufort, SC, USA
    Posts
    4

    Default I'll do that when the weat

    I'll do that when the weather clears here and in the mean time I can get the fuel line cleaned out and tighten all the fittings. Thanks

  9. #9
    Join Date
    Dec 2009
    Location
    Rotherham, South Yorkshire, uk
    Posts
    1

    Default "To Scott Lee Hi I had the sa

    "To Scott Lee
    Hi I had the same problem, It was fuel starvation,when I opened the throttle, the fuel filters were dirty and would not let enough fuel through so it cut out. I just cleaned the filters in petrol, put them back and it worked fine.
    Good luck
    alex"

Similar Threads

  1. Starts idels then dies as power is applied
    By bruce raykos in forum Archive 2002-2006
    Replies: 5
    Last Post: 06-21-2014, 08:34 PM
  2. 76 evenrude 75 hp no go when throttle applied
    By mace b in forum Johnson Evinrude Outboard Archive
    Replies: 1
    Last Post: 08-19-2008, 12:09 AM
  3. 1992 70 force DIES WHEN THROTTLE APPLIED
    By FISHING72 in forum Miscellaneous marine engine topics
    Replies: 1
    Last Post: 07-09-2008, 11:10 AM
  4. New 50 mpi breakin time before full power is applied
    By bob Fender in forum Archive 2003-2009
    Replies: 1
    Last Post: 03-20-2004, 09:59 PM
  5. Replies: 0
    Last Post: 12-31-1969, 08:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •