Logo
Results 1 to 6 of 6

Thread: Delay

  1. #1

    Default "So I am new to owning a boat

    "So I am new to owning a boat and have a MC 120 inboard 3.0. When I put it in gear I have a delay (it starts to go then putters and then goes). This is very irritating when trying to get up on skis or a wakeboard. I changed my fuel filter and spark plugs and played with the richness which has made it better, but not perfect. Any suggestions, or is this something I need to take to a shop and have them do it? Also my speedometer doesn't work do I just need a new one, or is it usually something else (like the cable or something)?

    Thanks for your help."

  2. #2
    Join Date
    May 2007
    Location
    Kawarthas
    Posts
    3,224

    Default "could need a carb rebuild- so

    "could need a carb rebuild- sounds like the accelerator pump may not be giving it's proper squirt on acceleration. Therefore, the mixture leans out when you juice it.

    Also a tune up may help.
    Plugs was a good start, but that's not a tune up.

    speedometer issue could be weeds on the pitot tube.

    The speedo has no cable - it works from water pressure as the pickup is dragged along behind the boat.

    Some of the pickups pivot up and out of the way when you trailer the boat. maybe you just need to pivot it back down."
    Factory Manual Best, Seloc 2nd best, Clymer if you're desperate.

  3. #3

    Default My speedometer is the kind tha

    My speedometer is the kind that has the hole in the lower unit. I am not sure if the hole was clogged but I do know that it is not clogged now. I will try to ru it and see if it works. On the tune up side is that something I can do or do I need to take it to a shop?

  4. #4
    Join Date
    May 2007
    Location
    Kawarthas
    Posts
    3,224

    Default "[i]My speedometer is the kind

    "My speedometer is the kind that has the hole in the lower unit.

    that's still a pitot tube, there is no cable.
    A hose runs from the drive to the dash. Often the hose is kinked or disconnected at the drive end."
    Factory Manual Best, Seloc 2nd best, Clymer if you're desperate.

  5. #5

    Default I took off the speedometer and

    I took off the speedometer and took an air compressor and blew from the inside of the boat out and heard air coming out down by the lower unit (I coundn't hear exactally where). I am hoping the hole was just clogged. What are the two wires that are attached to the speedometer (they attach to a metel peice that it attached to a light). Is it just that a light for at night when the lights are on? I have never had it out at night.

    Thanks

  6. #6
    Join Date
    Mar 2009
    Location
    Lowell, MA
    Posts
    1,217

    Default "The 2 wires on the speedomete

    "The 2 wires on the speedometer are for the light.
    you may want to tilt the drive all the way up and get your head under there and look at the hose and connection, if the drive was removed lately if may have been over looked in its replacement."

Similar Threads

  1. CDI 50 SEC DELAY
    By steveog in forum Chrysler Force Outboard Forum
    Replies: 5
    Last Post: 11-24-2009, 03:15 AM
  2. Delay when dropping the hammer
    By tchadwick36 in forum Mercruiser Sterndrive Archive
    Replies: 6
    Last Post: 07-02-2008, 02:29 PM
  3. Major delay in throttlewhy
    By Steve Bratchie in forum Johnson Evinrude Outboard Archive
    Replies: 5
    Last Post: 05-28-2008, 12:11 AM
  4. Delay Secondaries
    By tbrodes in forum Crusader Marine Archive
    Replies: 12
    Last Post: 03-02-2008, 01:17 PM
  5. Throttle delay any ideas
    By theporte in forum Mercury Mariner Outboard Archive
    Replies: 6
    Last Post: 07-19-2007, 01:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •