Logo
Results 1 to 7 of 7
  1. #1
    Join Date
    Apr 2006
    Location
    Winchester UK
    Posts
    186

    Default "I have posted about this befo

    "I have posted about this before but now it's doing something different. My trim tilt system operates fine either out of water or in water and at low speeds ie non planing speeds. As soon as the boat is under power, the pump runs but the drive leg will not tilt as in it cannot overcome the drive force of the propellor. If I tilt the leg slightly before putting the power on, the boat will naturally ride bow high as it gets on the plane and then rides nicely and the drive leg will hold its position but if I trim down, you can hear a bang as the leg drops down to it full down position it will not so much trim down as just let it go completely. My question is do you think the problem will be with the rams or the pump. As I said, the trim motor runs fine. Any ideas?"

  2. #2
    Join Date
    Aug 2006
    Location
    SW Ohio, USA
    Posts
    10,396

    Default Which pump assy? Please descr

    Which pump assy? Please describe w/year. Have you checked the oil level? If it has a metal can reservior did you turn the vent screw in until it bottoms and then back it out 2 full turns? Air in the system will make it act like it is.
    Fix minor things (replace wear items for preventative maintenance.) that cause major problems before they break.

  3. #3
    Join Date
    Apr 2006
    Location
    Winchester UK
    Posts
    186

    Default Boat is 1991 Celebrity Bowride

    Boat is 1991 Celebrity Bowrider. Pump has plastic oil reservoir and fluid is a greenish colour. Hope this helps.

  4. #4
    Join Date
    Aug 2006
    Location
    SW Ohio, USA
    Posts
    10,396

    Default "Has there been a loss of hydr

    "Has there been a loss of hydraulic fluid lately?

    Since it will hold pressure under a minor load but not a major one, I would suspect that the trim motor and/or pump is/are shot. My guess is the trim motor is the culprit. But, testing the entire system w/a set of gauges will confirm what the problem is."
    Fix minor things (replace wear items for preventative maintenance.) that cause major problems before they break.

  5. #5
    Join Date
    Apr 2006
    Location
    Winchester UK
    Posts
    186

    Default "Glad you think that as I am s

    "Glad you think that as I am set along those lines too. No loss of fluid has occured. This has been a fault for about 3 years but I do not use it too much. I just bought a new pump, motor and reservoir off ebay which looks good so will try that and get back. thanks for your help. Incidentally, do you know what the pressure should be?"

  6. #6
    Join Date
    Aug 2006
    Location
    SW Ohio, USA
    Posts
    10,396

    Default Make sure you go through the &

    Make sure you go through the "air bleed" procedure in the manual.
    Fix minor things (replace wear items for preventative maintenance.) that cause major problems before they break.

  7. #7
    Join Date
    Apr 2006
    Location
    Winchester UK
    Posts
    186

    Default "Replaced the trim motor/pump

    "Replaced the trim motor/pump assy but system still acts the same way. I have bought a set of seals for the rams and intend to fit them. Anyone have any experience of fitting these? Hopefully after I do that and bleed it, it should be ok. keeping fingers crossed as it cant be anything else unless the cylinders are scored."

Similar Threads

  1. Operation Range 74 l
    By tnsailorguy in forum Mercruiser Sterndrive Archive
    Replies: 1
    Last Post: 07-08-2009, 06:21 PM
  2. OMC Operation Questions
    By mlaymance in forum OMC Sterndrive and Inboard Archive
    Replies: 13
    Last Post: 08-14-2008, 09:13 PM
  3. OMC Operation Questions For 57 GM
    By ranisbet in forum OMC Sterndrive and Inboard Archive
    Replies: 1
    Last Post: 08-13-2008, 04:04 PM
  4. Operation of a 45
    By jimbo89 in forum Johnson Evinrude Outboard Archive
    Replies: 1
    Last Post: 06-10-2008, 11:06 PM
  5. Recoil starter operation on a 15 hp
    By floatr07 in forum Mercury Mariner Outboard Archive
    Replies: 4
    Last Post: 12-05-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •